zotero changing my entered webdav address - reupload of all files ?

edited February 21, 2020
I had to setup my webdav server after a hack completely new.

That means I have to upload all my attachments from my desktop to the webdav server again.

My old server address was myserver.xyz/remote.php/webdav and there I had a subdir /zotero where all my zotero stuff was stored.

On my new webdav installation I have created again the user "zotero", but now the home address given by the system is myserver.xyz/remote.php/dav/files/zotero/ .

Again I have created a subdir zotero there and tried to change the address in the preferences. So the final destination of my files should be

When I enter the address myserver.xyz/remote.php/dav/files/zotero/ immediately the /zotero/ ist disappearing and whenever I add it, it is removed immediately.

Is that an inbuilt feature or can I do something to have the address I want to have?

I have also started Reset - Replace Online Library - Reset . That should transfer all my attachments to the WEBDAV-server. The green circle starts to rotate and after a while it stops without an error message. States that synchronisation is done. Since my amount of data is big, that cannot mean that everything is transferred. When looking into my webdav-server there are no new files - neither in the home dir nor in the zotero subdir.

Where am I going wrong?
  • You don’t need to type the “zotero” part of the address yourself. That is added automatically.

    Replace Online Library is not the correct reset option. In general, never use these options unless you know exactly what they are doing, as you could lose data. You need to use the Reset File Sync History option.
  • Thanks for the input.

    The URL of my webdav-server contains the word zotero at the end, because I created the account with the name zotero. Within this account there is a subdir zotero, which should contain my data. That was the way it has been before.

    At the moment I have no data in the webdav-server space, so I cannot lose data there. I had the same problem some years ago. I cannot reproduce the solution now.

    The test of the webdav-server address says ok, thereafter a quite short sync time which in no way can sync my data and then syncing ends without error message. But there is nothing on the server.
  • edited February 21, 2020
    First, why not just use myserver.xyz/remote.php/dav/files/zotero/? I don't know if the interface will let you enter/keep two 'zotero' folders at the end, but I'm also not sure why you would want to.

    In any case, as bwiernik says, after configuring it properly, you need to do Reset File Sync History to cause Zotero to reupload all files that don't exist on the server.
  • No solution so far. What I have tried without success:

    In my Nextcloud server I had activated server side encryption. I thought this might be a problem and have reinstalled the server without encryption.

    Webdav-URL of the account with name "zotero" has the word ...../zotero at the end. Whenever I insert this address into the server address field, the "zotero" is knocked away. The same after manually inserting it. I created manually a subdir "zotero" in the account. That did not change anything. Server verification worked but not syncing worked.

    Then I created a webdavserver-account with a different name "refman", containing /refman at the end of the URL. This was not knocked away after inserting. I created a subdir /zotero, server verification is stated to have worked. There should be many hours of synchronisation between my desktop and the empty webdav-server in the internet, but a few seconds after starting syncronisation it ends without any error message and no new files on the server side.

    Any idea where I am going into the wrong direction?
    What could I reasonably reset when I want to get all my files to the server, which is empty at the moment?
    Server encryption is probably not possible to work with Zotero attachments?

  • I'm not seeing you mention that you actually did this:
    In any case, as bwiernik says, after configuring it properly, you need to do Reset File Sync History to cause Zotero to reupload all files that don't exist on the server.
  • @ dstillman
    your comment came at the same moment as I sent mine.
    The reason why I try to have the /zotero subdir is that I don't want to have the home dir of this account clogged with the many subdirs of Zotero attachments. That was the way I had it before with the old installation, where the URL did not end with ...zotero.
    I just tried again with the ..../refman URL account, resetted file sync history, started sync, it ended after about a second as before.....

  • OK…but if the account is just for Zotero, I'm not sure why it would matter if all the files were in the account root. And if it's not just for Zotero, I'm not sure why it would be named "zotero".

    In any case, can you provide a Debug ID for the first sync attempt after resetting file sync history?
  • edited February 21, 2020
    To be clear, Zotero will store its files in a folder in called "zotero" in your WebDAV account. You don't need to manually tell it to do that. What is the purpose of you wanting to have two nested "zotero" folders?
  • I don't know if the interface will let you enter/keep two 'zotero' folders at the end
    I just tested this — if you (for some reason that I don't understand) want /zotero/zotero at the end, you just need to enter it twice like that. The interface will strip one of them and leave the other, so with the hard-coded /zotero at the end it will come out to /zotero/zotero.
  • @bwiernik - this is a misunderstanding. I do not WANT to have two nested folders. It just results from what the system gives me. I have space at a commercial provider which supports Nextcloud ( www.nextcloud.com ) . I have installed a Nextcloud instance here and as admin I can create accounts as I need. I have created an account for my Zotero files with the account name and login "zotero". In the home directory of this account there is no subdir after creating it. From within this home directory the owner receives the URL of the home dir of this account from the server - it always has the name of the account at the end, in this case "zotero". A separate new dir /zotero created in this account has therefore an URL with two "zotero"s at the end of the address. That was the reason why I created an account named "refman" where the extra "zotero" was not kicked out. But that did not work either.

    @dstillman - I tried with /zotero/zotero - both were stripped, but this is the minor problem, since I can use the account refman or whatever I create. So I tried with the account refman. .....
    ok, file sync ist successfully set up
    File sync history resetted
    "The File Sync History for "My Library" has been cleared.
    Ok, ok.
    Clicking on the green sync circle
    Ends after a few seconds, when placing curson on it
    Sync with Zotero.org
    Last Sync 1 min ago
    Again resetting of file sync history
    Restart with logging
    Syncing - same as usual, ends after a few seconds.

    D1434734418 is the Debug ID

    Maybe a problem with Zotero not having rights to write files there??

  • You're just getting data sync error, which you should see an icon for next to the sync icon. You have an embedded image in a note that you need to delete.
  • @dstillman

    Thanks for the very probable problem solution!

    I know this error message, it has been present also in my last installation, too, but I didn't think it inhibited syncing - I just thought that these notes will not be synced, that's all. But maybe I did not follow the progress of syncing. Syncing is important for my two other Zotero installations in my laptop and the desktop in my condo, where I haven't been during the time which we used to call "winter" earlier. I used the laptop quite a lot and think that syncing worked but I never really checked.

    I have deleted the notes with the images in them and the syncing circle is rotating already for quite a while, though no data have appeared in the /zotero directory yet. Will let it run over night and sleep with fingers crossed....

    Could the program be changed so that it just omits these notes with images and does not stop syncing completely?

    Thanks again for all input to solve my problem.
  • edited February 22, 2020
    No syncing over night, no files in the webdav space. Green circle stands, red flag.

    Error message:
    The creator name “xyz…” in one of your items is too long to sync. Shorten the field and sync again.

    If you receive this message repeatedly for items saved from a particular site, you can report this issue in the Zotero Forums.

    I have adjusted the data of the item and the red flag disappeared and the syncing symbol started rotating again.

    As pointed out yesterday, I was not at all aware that Zotero won't sync at all if there is only a single error. Is there any way to check the library items for fitness for syncing before starting syncing?

    How much time goes before data should appear in the webdav-server space? Are all items checked before syncing starts to upload data?
  • Files appearing in the webdav-server space!!!! Great!!!
    Now problem seems to be really solved finally.

Sign In or Register to comment.