screen reader accessibility broken

Last two updates seem to have caused this issue. Using latest Jaws and word 2007, all works well except when trying to insert in text citation. On the menu's, selecting zotero, then entering on add citation, the drop down list when typing is not spoken so I cannot select the appropriate author.
Is there another way to insert citations into text or can I roll back to a earlier version until issue is fixed.
  • Is there something you normally press to type in the citation dialog? With JAWS enabled, I'm not able to type in the citation dialog at all. It starts to read some code (beginning with "data:"), and we can fix that, but I'm not sure how to type at all — it seems to interpret everything as a command key rather than input for a text field. For example, if I press "T" it says "There are no tables on this page".
  • @Carel.Ewald.1: As a temporary solution, though, you can use the classic dialog, either by selecting it from the drop-down menu to the left of the text field in the citation dialog or by setting it as a the default in the Cite pane of the Zotero preferences (which you can access via the Edit menu).

    But if you're able to tell me how to type in the citation dialog, I'll see what's happening with the search results.
  • To start typing in the edit field, you have to press jaws key (insert) and Z, it will say "quick keys off", then you type the citation you want. normally, it would read the first option, and when pressing the down arrow you will go to the next option in the list. this is where Jaws and NVDA keeps quiet, although the authors are there, it is not spoken.
  • Activated the classic view and am at least now able to access the citation. Longer workaround but at least do-able - thanks for the tip. Looking forward to resolve the original issue, let me know if you need any further info.
Sign In or Register to comment.