Run-time error'5' in Office 365 Word for Mac

Hi, Zotero has been working perfectly until recently when the following error message box started appearing:
Visual Basic for Applications
Run-time error '5'
Invalid procedure call or argument
Help or End

I have searched other threads but haven't managed to find a recent answer or a solution?

Running OS Catalina 10.15.2
Word for Mac version 16.32 Office 365 subscription.

I have tried uninstalling Zotero and removing it from the Word startup folder.
  • edited January 9, 2020
    Make sure you have the latest version of Zotero (5.0.81), remove from the Word startup folder, restart Word to make sure the Zotero toolbar is completely gone from Word, and then try reinstalling the plugin from the Cite → Word Processors pane of the Zotero preferences.
  • Hi, dstillman,

    I did all of that, twice, nothing changed??

  • Can you provide a Report ID after this error occurs?
  • Report ID: 2129427457

    The report showed no errors? I have taken a screenshot of the error message, but cannot attach it here?
  • @adomasven might have some other suggestions.
  • This is what clicking the help button on the error box produces, but I don't know what it means. it is a link to

    Some part of the call can't be completed. This error has the following causes and solutions:
    An argument probably exceeds the range of permitted values. For example, the Sin function can only accept values within a certain range. Positive arguments less than 2,147,483,648 are accepted, while 2,147,483,648 generates this error.
    Check the ranges permitted for arguments.
    This error can also occur if an attempt is made to call a procedure that isn't valid on the current platform. For example, some procedures may only be valid for Microsoft Windows, or for the Macintosh, and so on.
    Check platform-specific information about the procedure.
    For additional information, select the item in question and press F1 (in Windows) or HELP (on the Macintosh).
  • Excuse my ignorance, but does this (@adomasven might have some other suggestions) mean he will see this thread or do I have to message @adomasven separately?
  • He will see this thread.
  • Is Word installed in the default location (/Applications/Microsoft If not, could you try moving it there and see if it works?
  • Thanks, adomasven, but it is in the Applications folder. I uninstalled and reinstalled Office 365. I get 365 through my university, would that make a difference?
  • edited January 10, 2020
    I get 365 through my university, would that make a difference?
    No, that is fine.

    So neither Zotero, nor Word is in a folder that contains any non-alphabeth symbols? Could you create a new user account on your Mac and test there?
  • "So neither Zotero, nor Word is in a folder that contains any non-alphabeth symbols?"

    Sorry, but I don't know what that means?
  • The path to Zotero (e.g. /Appliactions/ and Word (e.g. /Applications/Microsoft should not contain non-alphabet symbols (e.g. 123!@#$%ąčėį)
  • Clicking on Get Info - name and extension of both apps shows only what you have suggested i.e. and, no other symbols. I hope that is what you mean?
  • And both of them are installed in the default applications folder, no subfolders? Could you create a new user account on your Mac and test to see if it works there?
  • They are where they get put when I install them, the applications folder. I don't mess around with locations in case I do something I don't know how to get out of.
    I guess I could create another user account, but that doesn't fix the problem even if it works, surely?
  • I don't know what to do once I've created a new user account either! Following instructions I can do, having prior knowledge I can't. I realise I am not very helpful, sorry.
  • edited January 12, 2020
    First, just to make sure, this happens in a new document in the old Mac user account too, right?

    Assuming that's the case, just open Zotero in the new Mac user account, add an item, and try to cite it, and see if it works.
  • Thanks, but this is no use to me because I do not understand what you are asking. I tried creating a new user account after Googling how to do it. Zotero was not in the new user account so I could not "just open Zotero in the new Mac user account". I assumed, which I hate doing, Zotero had to be moved to the new account and now my entire library / database is gone. I have uninstalled Zotero and reinstalled it, but it is still empty. As I said, you are assuming I have knowledge of how computers operate which I do not. I either need instructions or a guide, either on here or video otherwise it is pointless you asking me questions, but thank you for trying to help.
  • edited January 13, 2020
    The same Applications folder is available to all user accounts, so there’s no reason you shouldn’t be able to open Zotero in the new account if the Zotero application is where it’s supposed to be. The library will be empty, since you won’t have any data from the other account.

    You should undo the moving of the Zotero data directory, if that’s what you did that caused Zotero to be empty in the old account. All we said is to open Zotero in the new account, not to move anything.
  • If "Zotero had to be moved to the new account" then wherever you had it installed was not the correct location, which likely could have been part of the problem. You should make sure when you open Finder and select Applications in the left sidebar that that folder has both Zotero and Microsoft Word in it.

    What you should try is to open Zotero in a new macOS user account, create any citable item (either via the Zotero connector or manually via the Add Item option in Zotero), then open Word and see if you still get an error when trying to cite. Do not worry that you do not see your library, it is still there in your original user account.
  • dstillman - I tried dragging everything back that I moved, but something was obviously missing. I expect I have since deleted it. I now realise I was still in my original user profile trying to move things which is why I couldn't see Zotero (see, I told you I am an idiot).

    adomasven - It does have both in the applications folder.

    I have figured out what you mean, managed to create a new user and login (I didn't realise I had to switch users - still and idiot) using the new profile, create a document and citation, but have the same resulting error message.

  • Unfortunately, I don't think we have a solution for you. We get a report with this error message once a year or so and I don't think any of our users have been able to fix that. You could try reinstalling Word but if that does not help, then the only option I can think of is fully reinstalling macOS (or performing a factory reset). I would not recommend doing the latter on your own if you're not comfortable with the technical part of computer maintenance since there are risks of losing your data if you do not take the appropriate measures.
  • Bugger!
    I have reinstalled Word after an issue with its updates. It could be a Word issue because Office for Mac has never been 100% stable. Every time Microsoft issue an update; usually every half and hour, but I may be exaggerating, something goes wrong. Thank you both for trying and your patience with my fumbling efforts.
    For what it's worth the university only supports Endnote and that isn't working properly either, so it could well be a macOS Catalina issue. Who says technology is supposed to make our lives easier!
  • For what it is worth I downloaded Chrome today and tried to use Zotero with that and got the same results. The browser plug-in works perfectly. Logically this would suggest it is a compatibility issue with Word or a Word update has buggered up Zotero. Just thought you may want to know.
  • Yes, this is an error from Word, so the browser extension is entirely unrelated.
  • Are there any updates on this issue? I'm working from home and am having the same error message pop up.
Sign In or Register to comment.