Source item for keyed source doesn't exist in Zotero.Item.getSource()

Today I started getting the following error when trying to sync with my office computer:
"Source item for keyed source doesn't exist in Zotero.Item.getSource()"

The report ID is 1173078112

The only thing I did recently was sync from my home computer. I'm running Zotero 2.0b3, Firefox 3.0.10, Windows XP SP3.

  • I'm having the same issue with my office PC. The report ID is 1949250328; I'm running Firefox 3.0.10, Zotero 2.0b4, and Windows XP Professional version 2002.
  • Ditto the same problem. Report ID is 1082358025.
  • Syncing has never worked for me. It shows 40 items in a pop up window- when I press merge documents the very first time it crashes with this error. the zotero updates for the last one year has not helped this issue. Any clue regarding firefox settings or zotero settings will be of much help.
  • Try resetting your sync on the computer that has the errors. Choose "Restore from Zotero server" in the sync "reset" tab preferences on this computer. This will erase data on your local computer and restore the data saved on the Zotero server to your local computer.I would make sure to have a backup of this data on the "original" computer that actually has all the data. As long as your Zotero server data is up-to-date this should work perfectly. This helped me. Good luck.
  • I just got this problem too, ID 1532574918.

    It happened after I spent some time inputting a load of new refs so I really don't want to resent from server. Any suggestions?
  • This should be fixed in 2.0b6, available now.
  • I've updated to 2.0b6 but am still getting the same error.
  • I updated to 2.0b6 and I can now successfully sync without an error. (Sorry capitalrefs!)
  • capitalrefs: Upgrade to 2.0b6.2, try again, and send in another error report if it fails and post the Report ID here.
  • edited July 29, 2009
    Thanks Dan.

    I've installed 2.0b6.3 and am still getting the same error as above when I try to synch:

    Source item for keyed source doesn't exist in Zotero.Item.getSource()

    Not sure where to find the error report ID, sorry.
  • Restart Firefox, do a Full Sync in the Sync->Reset pane of the Zotero prefs, and, if you're still getting an error, post a Report ID.
  • I tried a full sync but it didn't do it. The green sync button immediately has a yellow cross on it. The hover-over message reads:

    Sync with Zotero Server
    Last error: Background sync resulted in conflict - manual sync required

    When I click the green sync button I get the same message again I posted above earlier.

    I've now found where to go for the Report ID: 1011844799
  • If you can generate debug output for the full sync and send it to, with a link to this thread, we'll take a look.
  • capitalrefs: You should not be able to get the background sync error from doing a manual full sync. First, disable auto-sync in the Zotero sync prefs. Then restart Firefox and open the Zotero pane. In the preferences, start a full sync. If you get an error at that point, without doing a manual regular sync, send in an error report.
  • That's done it. Thanks ever so much Dan.
  • OK, great. Feel free to turn auto-sync back on—that was just to avoid interference with the full sync.
Sign In or Register to comment.