Unintuitive UI when adding items while viewing the "My Publications" collection

Report Id: 1298912307

1. While viewing the "My Publications" collection, the "New Item" button on top is not working, but does not indicate why.

How to reproduce: Go to your "My Publications" collection and hover over the plus icon on top.

2. While viewing the "My Publications" collection, adding a new item via the File -> New Item menu gives no feedback to the user. However, a new item is being created in the background and resides in "My Library".

How to reproduce: Go to your "My Publications" collection and create a new item via the menu (File -> New Item).

Thank you for your great work!
  • Thanks. File → New Item (and Add Item by Identifier) should just be disabled, like the New Item toolbar button. Issue created.

    Just to clarify, you're not meant to create items manually in My Publications. You just save them to your library normally (e.g., from the browser connector) and then drag them to My Publications. Dragging an item triggers a prompt with additional steps, which wouldn't really work for manual item creation (which should almost never be used for modern items anyway). I suppose we could leave these options all enabled and show an alert if they're used, but I'm not sure it's necessary, since the text in the middle pane of an empty My Publications explains how to add items.
  • Thanks for the reply.

    To give you some background on my use case that resulted in the issue: I typically add items just like you described and understand that this is the way to go. My Publications has not been empty for so long that I do not even remember there was a text in the middle. In this particular case, I wanted to add an oral presentation where the ideal way was not possible, since there was no .ris, connector-suitable web page, etc.).

    The reason I added the item through the menu was because the plus button was not responsive and I did not understand this as being intentional.

    Suggestion: Set the plus button not only disabled but also set its color to gray. Ideally, provide an explanation via the tool tip.
Sign In or Register to comment.