can not open Zotero

I installed and used it for a few time, and change the file folder from C:\ to D:\, and it worked for a while. But all of sudden it does not open anymore, with this message:

Error: Could not open connection to D:\Zotero files\zotero.sqlite: 2153971714
From previous event:

I uninstralled and reinstalled the software, still the same error message.

  • Is D: a network drive? If so, that may not work. It does in some network drive setups, but when it doesn't, pretty much the only thing we can suggest is to move the data directory back to the local hard drive.
  • It is not network drive, it is local drive, a sim memory card. my drives are solid state drive any way. What is the procedure to switch the directory back when the program does not start?
  • edited November 23, 2019
    Well, it's a generic I/O error — I'm afraid that's really all we can tell you.

    If you just move the data directory back to the default location, Zotero should detect that it's missing (assuming it can access the disk at all) and prompt to use the default location instead. If you continue to get the error after moving the directory, you'd have to open prefs.js in the Zotero profile directory in a text editor and delete the dataDir line.
  • Thanks,
    Why I uninstall and install it again still not working? Somehow it remember the error. pretty strange.
    I am not an expert in computer, can you write me an instruction, where and how to and how to move the folder? Thanks!
  • Uninstalling doesn't affect your settings or data.

    Did you not move the data directory to the D: drive in the first place? Or did you just change the setting without moving anything? Do you actually have any data currently that you're trying to keep?
  • I did not move the directory, just changed the directory setting on the program when it was running.
    I don't have much in the folder as I am new to the software. anything you can do enable the program to run again will be ok.
  • edited November 23, 2019
    You can just close Zotero, go to the Zotero profile directory, and delete prefs.js. That will reset all settings, so if you've set up syncing or the like, you'll need to set that up again.

    If you want to avoid setting things up again, you can open prefs.js in a text editor (e.g., Notepad), delete the line containing "extensions.zotero.dataDir", and save the file, which will only reset the data directory setting.
  • edited November 23, 2019
    It is google chrome

    and the file in the C:\program Files(x86)\Zotero\defaults\preferences\prefs.js, cant find the " extensions.zotero.dataDir" , I copied the whole script file with "extensions...":

    [removed — D.S.]
  • That's the Zotero application directory, not the Zotero profile directory. (I wrote "Firefox profile directory" the second time, but I meant "Zotero profile directory" both times.)
  • Got it, Thanks
    You think this is just a one time error, and it should be ok to use D: drive?
  • Thanks again, it turns out the Journal file is corrupted. replace the journal file and it works for d:\ drive as before.
  • Now the folder is corrupted, can not open.. why is that? lost my whole collection..
  • A SD card really isn't a stable place to store data. If you mean that the folder itself is corrupted, that's a filesystem-level issue, and we obviously can't do anything about that. If just the zotero.sqlite database is corrupted, you can try restoring from one of the last automatic backups, or try the DB Repair Tool. Otherwise, you'll need to either restore from another backup or, if you've been using Zotero syncing, delete the database file and just let Zotero sync down data from your online library.

    In any case, you should move your data directory back to a real local drive. An SD card shouldn't be used for permanent storage of important data.
  • Yes, just the Zetero folder not working. will try the last automatic backups
  • the zotero does not run, can try to reinstall it.
  • edited March 16, 2020
    This doesn't have anything to do with the Zotero application files, so reinstalling isn't going to help. This is about your data files. It sounds like yours are corrupted from storing them on an unstable SD card, so you'll need to restore from a backup or delete the database and let it sync down your data.
  • Sir:

    It says the zotero.sqlite file is corrupted. and refused to work. How can we recover from it?


  • You can try to upload it to to see if it can be fixed
  • Otherwise, if you’ve been syncing, you can delete the sqlite file and then re-sync to make a new copy
  • Awesome, it works!

  • Sir:
    does this link still works?

    This site can’t be reachedThe webpage at might be temporarily down or it may have moved permanently to a new web address.

    Do you have the updated link?


  • Yes, it still works. If it's still failing for you, something about your network connection may be causing the upload to time out. Try again, or try from a different network. You can also try the manual steps linked from there.
  • D Stillman:
    I tried upload corrupted zotero.sqlite file and download the fixed one, still can not open the zotero. Can you help? thanks Lee
  • What's the Upload ID?
  • Upload ID 6270d98621f6d
  • edited May 3, 2022
    That database isn't corrupted. Why did you think it was?

    What's the actual error you're currently receiving in Zotero? I explained that the original error you were receiving above was just a generic error with Zotero not being able to properly access the disk.
  • I can not start the program:

    There was an error starting Zotero.

    You can report this problem in the Zotero Forums.

    Error: Could not open connection to D:\Zotero\zotero.sqlite: 2153971714
    From previous event:
  • I explained this above. If you can't move the folder back to your local disk, that's a problem on your system that you'll need to fix. This isn't a problem with Zotero, and it isn't something we can help with.
  • DStillman:
    it is local in my computer. Local drive has to be the C: drive?
    I cam move the folder back to c:drive to see if that will work.
Sign In or Register to comment.