Sync Problem with 2.04b

Hi, i am having a sync problem with 2.04b
It works fine with same login on my other 'puter.

Firebug says:
[Exception... "'[Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [mozIStorageStatement.execute]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: chrome://zotero/content/xpcom/data/collection.js :: anonymous :: line 551" data: no] [ERROR: not an error]' when calling method: [nsIDOMEventListener::handleEvent]" nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)" location: "<unknown>" data: no]
  • That's interesting: [ERROR: not an error].
  • I'm receiving exactly the same error while trying to sync. Zotero 2b4, Ubuntu 9.04 FF 3.0.10.
  • Error Report: 289908740

    I have two computers, one mac, one pc. Both have the latest 2.04b, and the latest firefox.

    Syncing works fine on the PC.

    On the Mac, I seem to have 2 problems. When I open the Zotero pane it starts to Sync. It comes up with an error message which includes comments about invalid integer value application PDF & etc. (I wonder if this has something to do with the indexing problem with PDFs that has been noted and fixed, so I'm told, for the next build release).

    Then, what often happens (although I can't get it to happen right now) is that a pop down box informs me that there is a sync in process that has not been completed and do I want to reset (or some such). It doesn't matter if I say yes or no, I then end up with a version of the above error message.

    Perhaps this will all go away with the next release of the beta; any advice gratefully received.

  • Error Report: 818960482

    Seems I have a similar problem. I have been working on a XP desktop, which worked fine, but switched to a Vista laptop. I added 3 references with attached pdfs (dragged and dropped) on the laptop and now cannot sync from the laptop. I deleted what I thought were the three offending references and pdfs, but without result.
  • I am having the exact same problem as Anthony - the error I get is: Invalid integer value 'application/pdf' [QUERY: UpdateAttachments SET Sourceitem ID=?, linkMode=?, mimeType=?, charsetID=?, path=?, syncState=?, WHERE ItemID=?]

    Changes I made to a linked pdf have not been updated for some reason.

    Any help with this would be greatly appreciated.
  • I'm having the same problem, using Zotero 2.0b4 on Mac OS X 10.5.7. Error report: 2015297574

    I've tried restoring my library from the server, and I've tried uninstalling Zotero, but none of these has worked.
  • Anthony, mkwalker, cahafner: That's this problem. It's fixed on the trunk, and the fix will be included in 2.0b5, which should be available shortly.

    meelis: You didn't provide an error report.

    paulM(MNA), lmullen: Could you send debug output for the sync attempt to, with a link this thread? Thanks.
  • paulM(MNA), lmullen: Your error may be fixed now. Let me know (and provide a new Report ID) if you're still having trouble. Thanks to lmullen for sending debug output.
  • me too, the report ID:915471018

    Sync has problem since 2.04b
  • Yichao: There are no Zotero errors in there. Make sure you send in the error report after the problem occurs and before restarting Firefox.
  • The error is still here: report ID 430061898.

    Version: 2.0b5

    It appears at my home mac, while works fine with XP at work. The "Restore from server" function did not help at all, but deleted all the library locally.

    The following is a list of other Firefox plugins I am using:
    Adblock plus
    Diigo bookmarks
    Download statusbar
    Evernote Web Clipping
    Todoist sidebar
  • I have the same bug still in 2.0b5 also. ReportID: 1562480851

    Happens at home and at work, running firefox 3.5b99 on debian lenny and 3.0 on ubuntu jaunty. Using extensions ABP, noscript, greasemonkey.
  • Oh, I have the debug=true log if you want it.
  • See Troubleshooting Sync Errors. If you can wait, an upcoming build of Zotero may offer an additional reset option that will be able to fix the "not an error" problem (which in the latest build has a better error message) without needing to do a one-way sync that overwrites either your local database or the server.

    By the way, this error could've occurred if you got the "Another sync still in progress" message and reset an active sync session (though there could be other causes as well).
  • My workstations have diverged with some significant bits before I noticed. I guess I'll just wait for the next build and save the server a bunch of hits.
  • Thanks for the response, Dan.

    I am anticipating for a new build now!
  • Also having some error problems with 2.04b. Report #: 411214388
    I'm on a PC running Firefox 3.0.11.
  • edited June 17, 2009
    Just in case this information helps in any way, I've got the same too,
    with 2.0b5. Report # 946298430.
    This is a PC runing Windows and Firefox 3.0.11.
    many many thanks for making zotero such a great tool!

    I decided to do a restore from server for this computer; It cleared the local library but failed to retrieve the data from the server.
  • edited July 8, 2009
    now, this seems wierd to me:
    On my other computer, syncing still works (see the above post).

    Here's the whole story with some more informations:
    1.) I initially created the zotero database by rdf import on computer A
    2.) Copied the whole databse via USB Stick to Computer B
    3.) Synced Computer B via RESTORE TO Server
    4.) Synced Computer A and got 47 conflict resolution messages (expecting none). As far I could see, the differences where in some special characters.
    5.) Tried to Sync Computer B - failed (See my last post)
    6.) Tried to RESTORE FROM Server Computer B - failed ( See my last post)
    7.) Synced Computer A - no Problem

    hope this helps debugging.
    Meanwhile I'm fine without syncing and wait for the next release.

    edit on 8/6/2009: 2.0b6.2 fixed this. Thanks!
  • edited June 18, 2009
    I'm getting the same error again. Reported (ID 1763030093).

    FF 3.0.11 Ubuntu 9.04 Z2.b5
  • I get the same error message as paulM(MNA) (report 1672560033) in the current trunk build (r4653) when trying to restore my collection. Incremental syncs on other machines seem to be fine. I have not yet tried to restore data to the server from one of the machines that appears to be working. (I planned to just restore from backup, but can push working data later if it might be at all informative.)
  • Error report: 454568870

    "Conponent returned failure code: OX8000400F" is part of the message that comes up when holding cursor over sync symbol.

    Background: - as previously reported, 2 computers, laptop mac and work PC; the laptop mac sync perfectly everytime; the PC won't sync at all, as above
  • I got impatient, backed everything up, and pushed one of my non-syncing machines to the server. That fixed it.
  • Hi Lizard - what do you mean by "pushed one of my machines to the server"? I'm only your average computer user, so my technical skills are limited....

  • Firefox's Menu Tools > Addons > click zotero > click preferences > "sync" option at the top > "reset" tab > "restore to zotero server" > reset. Wait a long time, because it makes no attempt to tell you that it's busy sending data to the server. If I recall, a popup will tell you when it's finished.
  • I have a database of 3025 references which I imported from RIS format.
    Sync to the server fails with the same message ("Empty response from server"). I also tried using the "restore to server" option, with no joy.

    Firefox v3.5: report #906641

    Firefox v3.0: report #1675510355
  • I'm suddenly having a similar problem with sync, I get the "empty response from server" error on the sync button. I've tried a few things, like restoring to server (no luck, but oddly, "My Library" at Zotero is empty, so clearly Z was able to contact the server and delete the stuff there -- just not replace it with my local copy), upgrading from 2.0b4 to 2.0b5 (no luck), and restarting and trying various things.

    I generated a report for the most recent error: 307180.
  • I'm having the same problems with sync as PaulM(MNA):
    I have 2.0b5. My error report is: # 1543808208

    My library on my second PC was not updating with my library at work. I tried resetting to the Zotero server but this hasn't worked and I got the error above.

    Any help?
Sign In or Register to comment.