EZProxy infinite loop on Knovel

I'm having trouble access a resource, Knovel, through my institution's library when proxies are enabled with the Zotero connector in Chrome (Windows 10).

The problem is that the link from the library goes through EZProxy, then after a couple of redirects it ends up at a non-proxied page (https://app.knovel.com/web/) but seeing my browser as authorized by my institution, presumably based on a cookie. But the Zotero connector has learned that this domain needs to be redirected through the proxy, so it add the EZProxy details to the URL, which then gets redirected, forming an infinite loop.

Disabling "Enabled proxy redirection" in the connector extension fixes this, but of course makes it unavailable for other sites. Is there any way to exclude a particular site from proxy redirects?

  • There's a list of hostnames under the Connector proxy settings. You can remove individual entries there.
  • Thanks... found that setting.
    For anyone having this issue: it's under Advanced -> Config Editor -> proxies.proxies. Then edit the string to remove the unwanted string.
  • No, that's not necessary. There's a Proxies tab in the Zotero Connector preferences. You just have to click on that, select the relevant proxy, and then look at the hostnames in the section below.
  • Ah, thanks. The UI doesn't make it obvious that more options become available once you click on a proxy.
Sign In or Register to comment.