PDFs will not save to Zotero from any browser

I use Zotero a lot to add citations and full-text articles. I access my library's databases via their proxy server. When I attempt to save a citation with a "pdf full text" link on the citation page, everything is fine.

In cases where the article is listed as "linked full text," so clicking on that opens the PDF alone in a new tab, still proxied, I get either a red X when I try to download it, or an error message (see below). I have tested this in several databases (ProQuest and ScienceDirect, for example) and I THINK it's only happening in EBSCO databases, if that helps. The PDF itself isn't in EBSCO, it's in some other place (like coming from Sage journals, but it's opening via EBSCO).

I tried uninstalling and reinstalling Zotero, uninstalling and reinstalling the connector in both Firefox and Chrome, and am getting the same result. Can you help?

sample page on which this occurs: https://journals-sagepub-com.libproxy.umassd.edu/doi/pdf/10.1177/1084822319850819
Translator says "Save to Zotero (PDF)
Either I get a red X or it says An error occurred while saving this item.
Debug error ID: D549823565
  • journals-sagepub-com.libproxy.umassd.edu:443 uses an invalid security certificate.

    The certificate is not trusted because the issuer certificate is unknown.
    The server might not be sending the appropriate intermediate certificates.
    An additional root certificate may need to be imported.
    Your library's proxy server is misconfigured. See Incomplete Cert Chain for an explanation. You should report it to the library so their IT people can fix it.

    You can see the test results here showing that it's broken ("Chain issues: incomplete").
  • Hi, I'm the librarian who posted via nsouza2's account to report the problem above. I've consulted our systems folks and they don't think there's an issue with the proxy server or our certificate, after looking at your suggestions and links. The weirdest thing is that we can't duplicate the problem nsouza2 is having on anyone else's computer, even though we tested it in the same circumstances (on our wifi network, via the proxy). Can you think of other issues that might cause this problem? Security issues on the user's computer related to firewall or anti-virus software? Browser security settings? The fact that we can't duplicate the problem on any other computers seems significant, and makes us think that it's the computer, not the system.
  • The server's certificate chain has been fixed since yesterday (or there are multiple servers and the one the test is hitting today doesn't have the same problem). Yesterday the test displayed "Chain issues: incomplete", for the reasons explained on the linked support page. Today it says "Chain issues: Incorrect order, Contains anchor", which means it's still not quite correct but also wouldn't cause the same problem.

    So @nsouza2 should try again. If there's only one server, it should work now.
Sign In or Register to comment.