LibreOffice plugin toolbar buttons do not respond

This discussion was created from comments split from: Zotero toolbar is not working in LibreOffice.
  • I seem to be having the same issue. The toolbar buttons are present, but do not respond. At first, I did not receive any error messages.

    I am using Zotero 5.0.74 on Ubuntu 18.04.3 / KDE neon User Edition 5.16. I first noticed the problem today when using LibreOffice installed from the deb packages, but I have not used Zotero with LibreOffice in quite some time, so I do not know in which versions the problem first appeared.

    At first I did not have libreoffice-java-common installed, so I installed that package. No luck. I tried removing the LibreOffice plugin from within LibreOffice, then reinstalling from within Zotero. No luck. I tried disabling, then re-enabling the plugin from within LibreOffice. No luck there either. I upgraded LibreOffice to from the LibreOffice "Fresh" PPA, no luck. I repeated all of the above but still no luck.

    I removed the plugin from within LibreOffice then did a manual installation of the plugin from within LibreOffice. After that, I did receive an error message: "The version of the Zotero LibreOffice Integration component installed within LibreOffice,, or NeoOffice does not appear to match the version installed in Zotero. Please ensure both components are up to date and try again." I'm not sure if the error occurred in response to trying to enter a citation, or just starting LibreOffice. I cannot get the error to re-occur. If I try to insert a citation, LibreOffice hangs and I eventually have to kill it.

    I verified that I am running Zotero 5.0.74 via Help -> About Zotero. I had installed the plugin from /opt/zotero/extensions/ I checked the application.ini file in /opt/zotero and it has Version=5.0.74 and BuildID=20190821231635. I checked the extension version via the Config Editor from within Zotero and have extensions.zoteroOpenOfficeIntegration.version = 5.0.20.SA.5.0.74. Help -> Check for Updates from within Zotero results in No Updates Found, so I assume I have the most recent version.
  • (Moving this to a new thread. There's no general issue, and word processor issues are rarely related.)

    I would try moving your LO profile directory out of the way and trying with a clean installation (via Zotero if possible, or else manually) of the plugin.
  • No luck with a fresh LO profile either. I either get a complete hang of LO, or temporary hang followed by the version mismatch error message mentioned above.

    I decided to try a new Zotero profile too. I ended up removing ~/.zotero, ~/.cache/zotero, ./.mozilla/firefox/ks3vm77x.default/browser-extension-data/, and
    ./.mozilla/firefox/ks3vm77x.default/extensions/ to get a new profile. A new Zotero profile did not help either.
  • Can you provide a Report ID from Zotero?

    What version of Java do you have?

    @adomasven might be able to help further.
  • My Report ID is 630400064

    $ java -version
    openjdk version "11.0.4" 2019-07-16
    OpenJDK Runtime Environment (build 11.0.4+11-post-Ubuntu-1ubuntu218.04.3)
    OpenJDK 64-Bit Server VM (build 11.0.4+11-post-Ubuntu-1ubuntu218.04.3, mixed mode, sharing)
  • edited October 2, 2019
    [JavaScript Error: "Component returned failure code: 0x804b0036 (NS_ERROR_SOCKET_ADDRESS_IN_USE) [nsIServerSocket.init]" {file: "chrome://zotero/content/xpcom/server.js" line: 64}]
    Something is blocking the HTTP port that Zotero uses (23119). Restart your computer.
  • It looks like Zotero is listening on ports 19876 and 23116 on my system in addition to 23119.

    I closed all of my network-using applications and that did the trick. I probably had 200 tabs open across 3 different browsers. I suspect that one of those or another application accessing the network had bound up the ports Zotero wanted to bind to.
  • Yes, sorry, the bundled LibreOffice integration also binds to ports 19876 and 23116.
Sign In or Register to comment.