Zotero empty after moving documents folder

This discussion was created from comments split from: Moved Zotero folder-- now can't move back and all is gone.
  • Hi there!

    I have a similar problem - I inserted a microSD card into my laptop as I needed more storage, and moved my documents folder, including zotero, across onto this. Now when I open Zotero, it is entirely empty.

    Even when I've tried to sync it with the (small) part of my library that is online, Zotero allows me to log in using my email and password, but then the same email and password do not allow me to sync.

    I can see all my files inside their folders inside the zotero storage folder. But there is nothing in the zotero program itself. I've copied the zotero folder back to the original laptop, but still no change.

    Any help much much appreciated!
  • You don't want to sync to fix this — you just want to point Zotero back at your previous data directory. (You can make sure syncing is working properly after you've resolved this.)

    If Zotero is empty, you didn't copy the zotero.sqlite file you were using previously — the 'storage' directory contains only attachment files, not data. So you need to find the previous zotero.sqlite file. Note that Zotero will create an empty database if one isn't present, so if you see one that's 1 MB or 5 MB, that's just an empty database.

Sign In or Register to comment.