Google Docs Hanging Up

Good morning,
I was unable to find a thread exactly on point. Apologies if there is one and I missed. If s, patience will be appreciated as you simply point me to the relevant posts. Otherwise...

When I click on Add/Edit Citations in Zotero in Google Docs a bocx appears saying that Zotero is preparing my doc. That box remains for a long time, nothing farther happens and I close Docs down and go to Word. Is this a glitch with Sotero? Am I dong something incorrectly? Or some other explanation and fix? Thank you!
  • (Don't worry about finding other threads beyond a very quick search. New threads are almost always preferable unless you're very sure you've found the exact same issue.)

    If you restart Zotero and Chrome, does this still happen? Does it happen in a new document? Can you provide a Debug ID from Zotero for this occurring?
  • I just tried again and have now been waiting 7 minutes and still I have a message on the screen that says, "Zotero is updating your document. Please wait..." I closed the doc and reopened to perform a second test. On the second test Zotero was totally unresponsive (i.e., nothing happened upon clicking on the Add/Edit Citation button. I made a copy of the debug report and saved it. I cannot locate a Debug ID anywhere. I followed the instructions for finding the ID in Zotero and was still unsuccessful.
  • The instructions explain how to generate the Debug ID.
  • Thanks. The Debug ID: D2023502721.
  • That's from the Zotero Connector. We'd want one from Zotero as well.

    But you should restart Zotero before trying again. That just shows that a request is already in progress. If the request is hanging, we'd want to see a Debug ID for the first attempted action since restarting Zotero.
  • Just ran the test again. Here are the two debug IDs
    D143203979 (Zotero Desktop App)
    D1985245609 (Zotero Connector)
  • And what exactly happened there? That looks like it opened the document preferences window and then there was a 14-minute wait before it was closed.

    Are you sure the document preferences or citation window isn't just appearing behind your browser? Those are part of the Zotero app, not the browser plugin, but they should be brought to the front automatically. Something on your system could be preventing that, in which case you might need to switch to Zotero to find the open window.
  • You were correct. The window was appearing behind Chrome. I didn't see it nor receive any notification that it was there. Once I found it, Chrome and Zotero worked together. Thank you.
  • Ahhha yes same happened to me and this thread helped :)
    Even the task bar did not alert me some new window opened.
Sign In or Register to comment.