I can't open PDF's

Please help! I cannot open my PDF files in either Zotero version (online and standalone)

I have done pretty much everything. My last option is to reset but I am afraid that I will lose my PDF.
  • edited June 21, 2019
    What exactly happens when you try to open a PDF in the Zotero program?

    Don't reset anything.
  • edited July 16, 2019
    I also have this problem.
    I'm using
    Zotero 5.0.69
    in Linux Mint 19
    Firefox 67.0.4 (Mozilla for Linux Mint 1.0)

    Zotero Preferences/General/File Handling/Open PDF's using drop down is set at System Default

    When I click on pdf file in linux mint directory it opens in Xreader
    If I put in a URL to the file in firefox it also opens the pdf file without a problem

    when I click on a record in Zotero it open up the Help application and consequently the PDF isn't opened.

    I recall earlier getting asked which application to use to open a PDF and the only application option I was given was the help application (with a lifesaver ring icon).

    Now I'm not asked which application to use it just automatically uses the help application.

    please help

  • thanks for that.
    I did look at the defaults.list file.

    The relevant line reads:

    so this appears to direct to the correct application.

  • Unfortunately, linux stores default apps in all sorts of places (other ones to check would be /usr/share/applications/defaults.list ~/.local/share/applications/mimeapps.list ... there are probably yet more options).

    Is selecting a custom app in Zotero not an option?
  • edited July 16, 2019
    When I select custom app the "Choose Application" dialogue opens up to my folders directory rather than a list of applications. I don't know how to select an application from my folders. Regardless, I understand that linux hierarchy is such that executable files aren't listed in folders (in contrast to MS Windows where executable files are available in the program files folder as .exe files...) ...
  • I just looked in the
    in /home/tomislav/.var/app/org.zotero.Zotero/config/mimeapps.list

    and the file contents in text editor was:

    "[Added Associations]

  • You should be able to select .desktop files, I believe. They're typically in one of these locations:

    Beyond that, linux applications are absolutely accessible as files. That's how they're launched. They just don't have a .exe file extension.
  • how do I know which file is an executable file? When I search for 'evince' to find the 'evince' executable file I get 100+ files listed. Most of them are text files etc. I don't know which file to select...
  • edited July 16, 2019
    I'm getting closer...thank you so much for helping me out!

    in the /home/tomislav/.var/app/org.zotero.Zotero/config/mimeapps.list
    I replaced
    ""[Added Associations]


    "[Added Associations]

    and now when I click on a file Zotero actually provides me with a list of relevant applications
    e.g. "Evince, document viewer, GIMP, Libre Draw" etc.

    when I select one of these file opens correctly.

    This is a big improvement. However it would be nice to not have to select a program every time.
    I don't know how to make one of these the default...

  • see above re: .desktop files. Those are launchers.
    If you can't select the .desktop file from the dialog, open evince.desktop with a text editor. That will have the file path to the executable. I'm afraid that's about as much support we can provide here. These are really fairly generic linux issues and you're probably better of on a distro-specific support forum.
  • Thanks for all the help. I am wondering if this is still a zotero specific issue.

    within linux mint I was able to locate the executable files as you suggested. They were in:
    here I was for instance able to find Document Viewer application which launches when I click on it

    however when I select custom app and I take the "Choose Application" dialogue to
    the list of applications is a much shorter and even different list. It's a short list of 12 .desktop files. The Document Viewer application is not in this list and neither are any of the other many applications.

    My guess is that Zotero is not accessing the /usr/share/applications folder as a root user. I'm not sure how I can give Zotero permission to access the folder as a root user....perhaps this is a linux mint issue, I'm not sure

    thanks again for all of your help.
  • Zotero should definitely not be doing anything as root (nor should that be necessary). Are you able to find the evince.desktop file? It's possible the choose dialog expects those and it's very likely it exists on your system.
  • When I search for evince.desktop

    I find the file I mentioned previously within

    when I request properties of this file I get the following:
    Name: Document Viewer
    Command: evince %U
    Comment: View multi-page documents
    Type: Text (application/x-desktop)
    Size: 1.2 kB (1,215 bytes)
    Location: /usr/share/applications
    Volume: unknown

    as mentioned above, I am not able to see this file in the zotero choose application dialogue....maybe because of an incorrect type?

  • I wonder if this is a clue to the problem:

    When I right click a pdf file in linux mint I get an 'open with' option. When I select 'other application' I get a dialogue "Open with" with the instruction 'Select an application in the list...'
    The list has three sections/headings:
    1) Default Application with Document Viewer listed
    2) Recommended Applications with:
    - Libre Office Draw
    - GIMP
    - PDF Mod
    3) Other Applications
    with basically a list of all my applications

    The options I get when I click on a file in Zotero is the same as items 1) and 2) above which makes me think that there is a bug in Zotero where rather than selecting the default application when I have System Default selected as the Zotero file handling option it selects the linux default application as well as the recommended applications

    It may be a linux list configuration issue, or perhaps Zotero is not selecting the correct list

  • In case it helps, I posted an error report.

    Report ID: 73364505

    The error was actually not a real error, it was an error produced when I forced Zotero to select a non-executable file under custom files option as the Zotero filing handling option.
Sign In or Register to comment.