URGENT -- Error with Word for Mac 2011 and Zotero

I just submitted an error report on Zotero but I'm not sure if it's giving the correct issue. The report ID it generate is 583594164.

This is an urgent matter as I am working on a paper that is due today and suddenly Zotero and Word are working together. I am working with the desktop Zotero version 5.0.67 and it says it is uptodate. I am have Word for Mac 2011 v14.7.3

Everything was working fine when one of the inputs items added to zotero with chrome add on did have the date for the citation. I added the date and clicked add citation in Word. I realised that the date I added was in correct after I had added the citation so I fixed the date in zotero and tried to add another citation and that's when everything stopped working. Every time I try to add a citation now its says:

'Replace this Zotero field?' even though there may not be an exiting zotero filed. I have no option but to click ok to add something (as cancel would take me back to where I started) and I add the citation i want and then I get the message saying:

"Zotero experienced an error updating your document. Would you like to view troubleshooting instructions?"

I haven't been able to find a solution in the troubleshooting section. I've made a new document. Tried on a different document. cut and passed. Deleted zotero. downloaded zotero again. deleted the collection with the citations that were an issue. started both applications. restarted my computer. started a new document. disabled and renabled Zotero LibreOffice Integration and Zotero Word for Mac Integration but nothing helps and I get the same messages above. if i don't click on ok or cancel soon it says something about an integration issue but gives no resolution to the problem.

Please help me asap as I can't even build a bibliography from zotero now and I will have to do it manually which will take forever.
  • Has your problem been solved? I've just found the same erreur. Thank you.
  • We're looking into a problem with Zotero 5.0.67 and Word 2011. We'll have an update soon.
  • @hamidz For your immediate problem, you can install the previous version of Zotero so that you can finish your paper until the bug is fixed. https://www.zotero.org/download/client/dl?channel=release&platform=mac&version=5.0.66
  • This is now fixed in Zotero Sorry for the trouble.
  • I had the same problem. Thanks for the quick fix. However, this time I could insert my citation in my text but then Zotero crashed... Will see is it occurs again.
    Word Mac 2011, OS 10.14.5
  • edited June 15, 2019
    Same here:
    Inserting the citation seemed to work, but then I tried to insert a bibliography below, and it showed the temporary field for a moment, then "Zotero quit unexpectedly".
    (This is in a new document.)

    Tested a bit more, and this seems consistent: editing citations appears to work (although I don't know if they might be corrupted somehow), but then adding a bibliography just makes the Zotero app window immediately disappear in the background followed by the error message.

    Note that I cannot generate a report ID because it crashes before I can do anything. (Is there a way to around that, if it would help?)

    @OC34, are we having the same problem specifically for inserting a bibliography, or is yours crashing while editing citations? I haven't tested enough to know if it might also crash for other reasons, but it seemed to only be for the bibliography for me.
  • @djross3 Yes it looks like it is the same problem. I started a new document , could apparently insert a new citation but when I tried inserting a bibliography Zotero crashed. It looks like the problem is now creating or updating the bibliography.
  • edited June 15, 2019

    The same error message appears on my screen.

    "Zotero experienced an error updating your document. Would you like to view troubleshooting instructions?"

    It appeared after a manipulation error on my part: I tried to insert a quote while the cursor was in the footnote.

    Everything crashed. Like you, I followed the debugging instructions, but nothing works. I uninstalled the plugin, reinstalled it, idem nothing does.

    It had never happened to me after 6 years of use. Unfortunately, this happens when I also have to finish an article. How did you manage to get out of it?
  • edited June 15, 2019
    @Tahles -- The only immediate solution is reverting to an older version of Zotero. See bwiernik's post above:
  • edited June 15, 2019
    Ok, it's working ! Thanks a lot @djross3 !
  • OK, please try, which we believe should fix the bibliography issue. Thanks for your patience.
  • edited June 15, 2019
    No, it's still crashing on the bibliography, and now seems like also sometimes when editing a citation.

    There was also a weird bug with the field in Word: I tried adding a page number, so from (Smith 2015) to (Smith 2015:9) and somehow the Word field split so that (Sm was plain text, and ith 2015:9) remained in the field. This of course generated an error when doing something else that this cite had been manually modified. It's *possible* I somehow clicked oddly while editing this, but I've never seen a field split in half before while editing it.

    Thanks for your work in resolving this! I'm getting a very unreliable feeling about something that was updated. Is there some way to know that the final update is really working and won't corrupt citations in the document?

    I can test more if needed, just let me know.

    Note: I'm testing this by restarting both Word and Zotero, but not my whole computer. If that would help, I can try that too.
  • Hi I'm using Zotero 5.0.67 too and Word for MAC 11 and have exactly the same problem as Hamidz - what is the solution?
  • I am still getting the error message that Zotero is experiencing an error updating my document.
  • I warn you about installing the new update I just updated and successfully edited a citation after having had the described problem all day. Then suddenly all the changes made in my document visible in track change disappeared and the edited citation as well, and Zotero shut down unexpected.
    I look forward to hearing from you again.

  • Sorry, that was just a build mistake — didn't actually include the bibliography fix and was identical to Please try again with
  • edited June 15, 2019
    OK, does seem to be working with some basic testing.

    Is there any more rigorous or specific testing you would suggest to confirm it works consistently? Or, if it seems to be working, does that mean it's reliable to use for important documents? (If it's just an interface issue, that's fine, but I want to be sure the resulting document isn't corrupt.)

    Thanks for your fast work addressing this.
  • For context, certain changes and updates to the codebase related to the plugin for Word 2016 unfortunately introduced some bugs in the plugin version for Word 2011. This has indeed been an interface issue, no document corruption is expected and the reliability should be the same as before 5.0.67.
  • @adomasven and others, thanks! I'll let you know if I notice anything unusual going forward, but that sounds fine.
  • I'll try the 67.3 update and let you know if I still have a problem. Thanks for resolving quickly these issues!
  • Many thanks to all of you! 67.3 seems to be working fine.
  • I am having the same problem. How and from where do we download "67.3"?
  • Or just Help -> Check for Updates in Zotero. Zotero should also prompt you automatically to update.
  • edited June 16, 2019
    @bwiernik thanks for the advice, @dstillman and others thank you for resolving this so quickly. Much appreciated!
  • Thanks for the advice -- Mac user here, and the update to the most recent version got stalled. Sticking with 5.066 for now.
  • edited June 18, 2019
    @lauragayle: This was fixed days ago, and you shouldn't stay on an old version. If the update isn't going through, the first thing to try is just restarting Zotero. If that doesn't help, you can just install from the download page.
  • We are using LO Here the problem 'Zotero experienced an error updating your document....' also appears this week after the update to 5.0.67.

    To be sure, I downloaded the latest version, but that doesn't help; Stepping back to 5.0.66 resolves the problem.
  • @arjan1234 are you using custom templates? If so, could you post to this thread and send us over a template that makes things broken? If not, could you start a new thread? Word issues are different from LibreOffice.
  • The incompatibility between Zotero 5.0.67 and Word 2011 was fixed in Zotero, available via Help → "Check for Updates…", so I'm going to close this thread. Please start new threads for any other issues you're experiencing.
This discussion has been closed.