zotero.sqlite.tmp size


I noticed intensive disk operations that eventually made my OS (Ubuntu) to freeze. The culprit, it turned out, was Zotero. More specifically, the zotero.sqlite.tmp was going from zero (after deletion) to 30GB and on until all available space in the partition was used.

My database is quite old - I have been using zotero since 2013. I'm using the last version (5.0).
I don't have additional storage quota, so I assume I can not just start a new database and sync my ~1000 papers (all with PDF) from the cloud. In total, database folder is around 3.5GB (without the zotero.sqlite.tmp).

Does anyone know how the zotero.sqlite.tmp is used by Zotero and why it is getting so freaking large?

  • That's definitely not normal -- I don't think there should be any sqlite.tmp with normal operation and it certainly shouldn't be larger than the regular .sqlite

    Anything unusual about your set-up? E.g. is the Zotero data folder in Dropbox or some other syncing folder? Does your database pass the integrity check under Preferences --> Advanced --> Files and Folders?
  • Yes, my folder is in Dropbox. I removed once more the .tmp and restarted Zotero. Added one paper, started Dropbox. After some time, the .tmp was recreated.

    Any known conflicts between Zotero and Dropbox?

  • Yes -- you shouldn't have any database files in Dropbox in general. For Zotero specifically, this is a known cause of all sorts of database corruption (and almost certainly the cause here -- might even be that Dropbox is creating the .tmp file trying to keep up with Zotero's rapid changes of the .sqlite file)
  • Ok, thanks for the input. I will remove it from the synced folder.

    By the way, the integrity check does not give me any feedback (not even through shell). Is this the expected behavior, or a sign the database might be corrupted (although not identified by the tool)?

  • Ok, never mind the integrity test. After moving the database out of Dropbox and checking again, I got a "No errors were found in the database.".
Sign In or Register to comment.