Zotero fails to open PDFs

After upgrading (today, 12.12.2018) Zotero is not able to open PDF or other files anymore. This happened on two computers of me both running Linux Debian.

System: Linux Debian
Software: Zotero via flatpak (newest Version)
Already tried approaches: Rebooting the computer (of course), reinstalling the Zotero flatpak, it did not help.

Steps to reproduce:
1. Update Zotero
2. Open Zotero
3. Click on triangle of item to show containing files (PDFs, LibreOffice files, webpage snapshots)
4a. Double click on a PDF file -> Nothing happens
4b. Right click on the PDF file + left click on "View PDF" -> Nothing happens

My Zotero also contains Libre Office files where I store summaries of papers I read and snapshots of webpages. Those can't be opened either. So, after the update it seems like Zotero is not able to start other programs anymore.

Any help would be highly appreciated!!!
  • I'd strongly suspect the flatpack installer, which isn't maintained by Zotero. We don't have any other reports of this, including among the many debian-type linux users. Are you able to test this on stock Zotero?
  • 1st thanks for the reply!

    Regarding your question:
    I uninstalled Zotero via flatpak, deleted the .zotero folder in /home/myname, updated the Debian repository and installed zotero-standalone from there. Unfortunately, things are the same.

    Now, a plain Zotero is starting up what is expectable since Zotero can't know where my library is, yet. However, no button executes its function. I can click icons like "File", "Edit" or the setting symbol underneath the menu bar and the corresponding drop-down menu appears but regardless of what I click there nothing happens. I can, for example, click on "Help" but when I click on "About Zotero" the drop-down menu disappears and nothing happens.

    This behavior occurs on both of my computers (both running the same Debian). I assume that this is exactly the same behavior than before. Since I only wanted to open a PDF I never tried the other buttons in the flatpak version but most probably they would have reacted like they do now.

    Furthermore, no other program on my computer seems to be affected. I am running several programs in parallel, like Texstudio, Matlab, Firefox, etc. and everything is working fine with them.
  • zotero-standalone from the debian repo isn't stock Zotero; it's also a third party package. Standard Zotero is the tarball downloaded from zotero.org/download unpacked, and run.

    I can't promise this will fix things, but that's the version Zotero devs are going to be willing to troubleshoot.

  • Thanks for clarification! Indeed, using the stock Zotero did do the trick. Everything is fine using the tarball.

    I preferred to use the repository or flatpaks, so I would get my updates automatically but having a running system is much more important. So, I will stick with the stock Zotero but I am really puzzled what went wrong with the other versions. However, that is a question I have to post in a Debian forum ;)

    Thanks again and have a nice weekend.
  • There appears to be an open ticket on the flatpack package about this: https://github.com/flathub/org.zotero.Zotero/issues/15 I'd subscribe to that for updates
  • Thanks again!

    I don't think that the problem mentioned in the flatpak forum is the same. There a dialog for choosing the PDF viewer is appearing whereat my Zotero problem shows no functionality at all. If I find something I'll post it here. For now, I consider the problem solved since I have a running Zotero again :)
  • This is happening to me too.
  • I encountered the same problem using the Flatpack package for Zotero in Debian Testing (Buster).

    It happened I was missing a couple of packages to make possible flatpack app integration with the rest of the system.

    I manually installed xdg-desktop-portal-gtk and flatpak-xdg-utils and the problem was solved.

    Without those dependencies, the app was complaining about the following:

    ** (zotero:7): WARNING **: 19:13:26.206: Cannot launch default application: GDBus.Error:org.freedesktop.DBus.Error.UnknownMethod: No such interface “org.freedesktop.portal.OpenURI” on object at path /org/freedesktop/portal/desktop
    Failed to call portal: GDBus.Error:org.freedesktop.DBus.Error.UnknownMethod: No such interface ?org.freedesktop.portal.OpenURI? on object at path /org/freedesktop/portal/desktop
    Possibly unhandled rejection:

    /usr/bin/xdg-open returned exit status 4

    Error: /usr/bin/xdg-open returned exit status 4

    My system was basically missing the xdg-destkop-portal service.
Sign In or Register to comment.