Available for beta testing: Move documents with citations between word processors

edited July 18, 2019
In the latest Zotero beta, it's possible to move a document from one Zotero-supported word processor to another while keeping active Zotero citations intact. With this feature, you can begin writing a document collaboratively in Google Docs and move it to Word or LibreOffice for final editing, or vice versa. (You can also use it to move documents between Word and LibreOffice without some of the problems inherent in Bookmarks mode.)

We've added instructions for specific word processors, but the basic process is the same: choose "Export Document…" "Switch to a Different Word Processor…" from the Document Preferences window, save the converted file, open it in the other word processor, and click Refresh to import it. While the process should be entirely reversible, we recommend doing the export in a copy of the file.

Let us know if you run into any problems.
  • I pulled the new code into Jurism and gave it a try this afternoon, with legal references entered in GD, then exported, then refresh/imported in LibreOffice. It worked a treat, with all extended fields intact and functional. (:thumbs-up:)
  • edited May 18, 2019
    Since this was a beta I tried to break it by damaging a reference in LO and transferring to Word. With the exception of the broken cite (ignored in the Word transfer); this worked "a treat" (with thanks to Frank Bennett for a new figure of speech).
  • Wow! (:thumbs-up:) indeed...
  • Great!! Just tried this out for Zotero-5.0.67-beta.12 / Zotero_Connector-5.056beta2 On the "how to" page to move between Google Docs and Word (https://forums.zotero.org/discussion/77416/available-for-beta-testing-move-documents-with-citations-between-word-processors), it would be useful point out that "ZOTERO_EXPORTED_DOCUMENT" will appear at the top of the successfully exported Google Doc - at this point you can then use Google Docs File > Export to save it as a Word doc.

    (I got a bit confused at first about the two "export" options. It is important to use Zotero's Document Preferences window "Export Document..." button first, then the Google Doc File > Export option after that)

    As an aside, if coauthors have been inserting Zotero citations into the shared Google Doc using their own Zotero library and you import the Google Doc into Word to "polish" it, Zotero won't be able to find those and will just leave text-based citations.

    This new functionality has nonetheless saved me having to re-enter a bunch of citations for Google Doc citations that I entered. Thanks again!
  • As an aside, if coauthors have been inserting Zotero citations into the shared Google Doc using their own Zotero library and you import the Google Doc into Word to "polish" it, Zotero won't be able to find those and will just leave text-based citations.
    That is not the case. Zotero embeds all the necessary data within the document for a citation and they will remain active, editable and will generate appropriate bibliography entries post import. If any citations that were inserted with Zotero became plaintext after import, please create a new thread and post the steps to reproduce the issue and we will take a look.
  • @adomasven, Something weird is going on then - it's as if the citations within a given paragraph edited by different authors (who inserted citations from their own libraries) have been scrambled, and while all the metadata is there in the converted Word document (as plain text) it didn't get slurped up by the Zotero standalone when I clicked "refresh" at the last step of the instructions. And another strange thing is that sometimes the link to a citation is retained in the Word doc (e.g. https://www.zotero.org/google-docs/?R03oPP) instead of it showing up as a Zotero standalone "updatable" field. How can I provide snippets of the document to you to show you what I mean (in a new thread as requested)?
  • It would be best if you could make a copy of the document in Google Docs pre-import and remove all surrounding text except for the few paragraphs where the issue is clearly visible, then share the document with support@zotero.org. Create a new thread describing the situation as best as you can, including how and by who the other references were created before this and link it via the google docs interface if possible.
  • I have sent an email with the Word doc and a description of the error and how/by whom the references were inserted, and shared the pre- and post-Zotero export Google Docs with the same email. Thanks!
  • @provartn We have pushed an update to the export code. Could you try exporting the document again and seeing whether it imports successfully in Word?
  • Yesssss, @adomasven! Works without issue now. It took me a couple of days to do a bunch of manual additions this week (boo), but...I am glad you were able to figure out what the problem was and fix it. I'll keep an eye out for the Chrome version of the connector with this functionality.
  • Indirect experience here, but Jurism with the most recent Zotero beta additions to integration.js and the Word for Mac integration plugin failed on two student machines with older software (WfM ver 14.xx), although it worked fine on my own installation (WfM ver 16.xx). Rolling back to the 5.0.18 Word for Mac integration plugin cleared the issue on the older systems.

    I checked for other relevant differences in JM code, and couldn't find anything (but if the latest Zotero beta works okay with older versions of Word for Mac, I may need to look harder).
  • By "failed" do you mean the plugin was not working for any operations, or did the export/import fail? The export/import has not been tested or enabled for Word for Mac 2011 and the option does not appear in the doc preferences for it.
  • Sorry, I should have given more details.

    On one system, attempts to insert a citation immediately triggered a "Do you want to replace this Zotero field?" pop-up. If "Yes" was selected, we next got the "Problem updating your document" pop-up after selecting a citation and attempting the insert.

    On the other system, we got only the "Problem
    ..." pop-up upon insert.

    I didn't capture debug logs, because I assumed it was a Jurism-specific issue (which it might be). I remember the error and can find the line number in integration.js, though, if that will be useful.
  • We should probably make it more explicit that this is not and will not be supported in Word for Mac 2011 to be honest. Word for Mac 2016 has taken by far the longest time to get working right due to the API idiosyncrasies and we will not be maintaining Word for Mac 2011 compatibility too for it.
  • Got it, thanks. Export/import is going to be eye-opening useful when it comes out. We'll recommend to our people that they upgrade their Mac Word installs.
  • I'd like to understand the implications of this: Under this new regime, are you saying that Scrivener exported documents/files using the RTF/ODF method (clunky as it is), and imported into OpenOffice and saved in its ODT format can now be imported into Microsoft Word, with the footnotes or endnotes intact and dynamic? If so this would be huge.
  • edited June 6, 2019
    You should be able to do that, yes. Or move the document to Google Docs, again with live citations intact.
    Edit: (Oops, missed that. As Dan says below.)
  • @mlaytner: LibreOffice, not OpenOffice. We haven't supported OpenOffice in years.
  • Sorry. Me bad. Meant LibreOffice of course.
  • This is very impressive!
  • Hello everyone! I am trying to export a Google doc with Zotero citations into a word document and got extremely confused with the procedure. Do you have a step by step procedure I could follow? thank you very much!
  • The procedure is described https://www.zotero.org/support/kb/word_processor_document_export

    Is there something specific you are having trouble with?
  • Thanks a lot!
    I have issues when I click on Zotero Preferences on Google Docs. Zotero gets open and then I select APA style but the red bar keeps loading without anything happening! I am not sure I have Zotero beta however....
  • Google Docs can get slow if you have many citations, but that shouldn’t affect exporting to Word. You need the beta version currently to export the document. Follow the instructions I linked to to install the beta and export the document.
  • I have apparently the beta version as no update are apparently required. Should I close everything and restart ? The bar keeps staying there and no export has been performed. Thanks for your help!
  • To be clearer, when I click on Zotero Preferences, I don't have any "Export Document" button coming up. A window pops up and I select APA style, then a red bar is popping up, showing progress and then it closes itself. Your help would be greatly appreciated !
  • If you don’t see the Export Document option, then you aren’t running the current version of the beta. Selecting a style is not part of the export process.
  • Well i don't know what to do because through Help in Zotero, it says that there are no update available. Should I reinstall it?
  • I have tried to reinstall it, but my Mac says that an updated version of Zotero has already been installed... I really don't know what to do :(
  • Yes, the top of the page I linked to will take you to the beta.
This discussion has been closed.