Zotero Google Docs is very, very slow

Hello devs. Love your work . Very excited to finally get to use Zotero and Google Docs together. This promises to be a pretty transformative way of collaboratively editing academic docs. For us, though, it's really slow. Like 30 seconds to insert one citation in a small doc without many citations slow. It's so slow that it renders it practically unusable for us, I'm afraid. One author on Win 7 and Chrome; the second on Mas OS HS and Chrome 70.0.3538.77. Stupid question but is this typical? Any ideas on how to speed it up a smidge?
  • How many citations (approximately) in the document? What citation style? How many pages? Google Docs integration is generally slower than Word or LibreOffice, although this is mostly out of our control and the limitation of the online nature of it all. If you are using a numeric style that renumbers every citation upon insertion, you are likely to experience slow updates and we recommend disabling automatic citation updates in the document preferences.
  • It's Harvard style. Seems that even in a long doc that doesn't have many refs (64 page doc, 50 refs) it just slows down to the point that it's quicker to add them manually. Thanks so much for your efforts developing this. I guess we'll have to go back to Word :-(
  • I had the same issue and disabled automatic citation updates in the document preferences.
    The issue is that I get the following error message when I now try to refresh the bibliography (Report ID: 635694133):

    429: Google Docs Authorization failed. Try again.
    "error": {
    "code": 429,
    "message": "Resource has been exhausted (e.g. check quota).",
    "status": "RESOURCE_EXHAUSTED"

    The issue has be reported previously on the forum: https://forums.zotero.org/discussion/comment/311121/#Comment_311121

    It seems that with ~100 citations the execution time to refresh the bibligraphy is above the default quota.

    Is-there a way to fix this so that I can have my bibliography back?
  • @nicolasrode Could you try installing the Zotero Connector beta version for firefox and see whether the refresh goes through there? It will still take a while, but it should complete.
  • @adomasven It works! Thank you for your help!
  • I want to export my document without the links to the Zotero website. When I click "Unlink citations", the document freezes. I guess this is because I have a large number of citations (> 100). Is-there a way to export the document and remove the links to the Zotero website? Thanks.
  • You should see the usual progress bar from Zotero when you choose to unlink citations and wait for the progress bar to disappear. What do you mean when you say "the document freezes"?
  • I meant that the progress bar did not move for >10 minutes, so I thought the process did not work. If I understand correctly, I just need to wait for a little bit longer and it should be OK?
  • We are working to make this process much faster in the future, but for now it can take upwards of an hour in a document that's very long. Currently a faster alternative is to select all text in the document (CTRL-A or CMD-A, depending on your OS), copy it, paste into a new document, go into Zotero document preferences and click OK once the prefs show up. You should see that the citations in the document will become regular text after a while.
  • Hi, this is such a great tool to be able to use Zotero in Google Docs. However it is still super super slow or just does not refresh at all. It just becomes unusable. It is not even clear what it is doing or if it is progressing at all in the background. I am finished editing and have all the references put in. But I cannot refresh and get no bibliography. Can you please get this thing working faster and more stable?

    I have installed the Zotero connector. beta Version... Reopened everything etc. does not get faster.
  • This is a limitation of Google Docs, not Zotero and we have used every possible optimization we could to get this working as fast as it can. If you had automatic citation updates disabled in the preferences, then the bibliography insert will need to bring all of those citations (should be coloured with gray background) up to date and will take a long time. You will just have to wait. If the progress bar window (part of Zotero group) is being displayed, it means it is processing the document. Moreover, the beta (and these changes will be available in the stable version soon) will now prevent you from editing the document while Zotero is working on it. You should allow the process to run for a couple of hours, or even overnight. If Zotero still shows a progress bar after that or you get an error you should then create a separate thread and we will work though the problem with you together.
  • I too am having this problem using Zotero in Google Docs. When trying to cite just a single reference, I get the message "Zotero is updating your document. Please wait…" and the window is stuck for >15 minutes.
  • How long is the document? If you refresh the webpage, how long does it take for your whole document to load in the browser, before you can scroll all the way down to the last page? How many citations do you currently have in it?
  • edited January 26, 2020
    Hi, I am using Zotero right now for the first time in Google docs. In my test document I am having this same problem. There is one sentence of text, and this is my first citation. It has now been "updating" for about 5 minutes, with no signs of progress. APA style, if that makes a difference. ETA: 10 mins later, no change, and Chrome did entirely freeze for a few minutes.
  • @brainbleach Look through Zotero windows and see if you have a preferences window, citation dialog or a popup waiting to be interacted with. Otherwise try citing again after restarting your browser and Zotero
  • I'm having the same issue on a short document with a limited number of references (on Firefox). I've been working with much larger documents without any problem in the past.
  • @Romain_B Please create a new thread and explain your issue in details, as well as any steps you've taken in troubleshooting.
  • Also finding the same issue - even on a document with just one paragraph, adding one reference takes forever :( Tried on Chrome and Firefox.
  • I have the same issue: adding a citation to a Google Docs document takes 30-60 seconds.
    I see the pop-up with the progress bar during this time.
    Even with a completely new, empty doc and automatic update off in document preferences.

    A few weeks ago it was working perfectly (2-3 seconds for adding a citation).
    Might be related with the recent update of Zotero Connector on April 9, 2020?

    (I'm using Google Chrome 81.0 with Zotero Connector 5.0.64 and Zotero 5.0.86 for Linux)

  • Anyone have a fix for this yet? Everything was working fine as of May 5th, but today I'm having the same problems as brainbleach and brian.hagen.

    (Chrome 81.0, Zotero Connector 5.0.64, Zotero 5.0.86 for Windows.)
  • If you're seeing this, we'd want to see a Debug ID from both the Zotero Connector and Zotero for trying to insert a citation.

    This isn't a general problem — inserting a citation takes a couple seconds for me.

    As explained above, make sure there's not just a window behind your other windows.
  • Same problem, inserting references went from 10 seconds around 5th of may to a minute or more.

    Across computers, internet connectivity and google docs.
    Was working on one of about 700 words, with three sources.
    Tried inserting into an empty doc its all the same.

    1906354666 from zotero itself
    D1459478475 from chrome connector

    Chrome 81 windows 10
    zotero 5.0.86
    Zotero connector 5.0.65
  • @CedricJ Was the operation recorded in the debug log particularly slow, and did you go through inserting a citation? The log you've submitted does not seem to show any slowness.
  • It took around a minute for the quick citation window to finish loading, i didnt try to insert anything this time but i have other times. Right now it does not respond at all. Thats also a phenomenon of the past few days.

    the connector is showing:
    [JavaScript Error: "Cannot access contents of url "chrome-search://most-visited/single.html?title=Meest%20bezocht&removeTooltip=Niet%20op%20deze%20pagina%20weergeven&enableCustomLinks=1&addLink=Snelle%20link%20toevoegen&addLinkTooltip=Snelle%20link%20toevoegen&editLinkTooltip=Snelkoppeling%20bewerken". Extension manifest must request permission to access this host."]

    I think it might be related to the update of chrome. There was a update on the fith, i see that firefox also updated on the 8th.
  • @CedricJ Are you sure you're seeing a slowdown and not just the Zotero citation dialog not showing up on top of Google Docs? Restart your browser and Zotero, then attempt to insert a citation in a new document. Make sure you look through Zotero windows when you initiate the operation, as the citation dialog may not properly pop up for you. Do you still see a noticeable slowdown? If you do, could you provide a Debug ID from the Connector for a full operation in a new document, from initiation to citation insertion?
  • The citation dialog took 2 minutes to finish loading. I could see the loading bar and saw it change to the dialog window. After selecting a source it quickly inserted the note in the doc. the speed at wich it actually inserts it seems to vary.

    The debug id from the connector is 22140352335

    it still gives the same javascript error. I have restarted both zotero and chrome i used a clean empty google doc.

    before submitting my request i have restarted my pc, used other pc's and diffrent notes. I have unchecked auto update. tried other styles.
  • (Your Debug ID was D2140352335.)
  • Sorry yes
  • @CedricJ Okay, this debug log does record some slowness. Could you submit another Debug ID from the Zotero itself for the same operation?
Sign In or Register to comment.