Copy Bibliography function in Edit menu not working

Error Report ID 1448179516. Under Zotero Preferences, I selected Chicago Manual of Style 17th edition (author-date). Every time I used "copy bibliography" from the Edit menu, it would produce a Chicago Manual of Style 17th edition (note) bibliography. I removed all styles except for the one I wanted to try and force it to cooperate. Now "copy bibliography" from the edit menu does nothing. However, the right-click context menu item "create bibliography from..." does create a bibliography entry in the correct style. But it has an intermediary step that is slower than using the edit menu option or they key command.

As an additional test, I added Chicago Manual of Style 17th edition (note) back as an available style and now it works again, but will only produce bibliography items in the wrong style. When I open preferences, no style is selected.
  • Where are you setting the style for quick copy export exactly?
  • Zotero Preferences - Style Manager

    I don't see anywhere else to do it. I click on the style I want, it's then highlighted, but that doesn't seem to do anything long-term, but I can't find anywhere else where I can make this selection.
  • Quick copy is set up under Export --> Default style. What you select or have in the Style Manager doesn't have any impact.
  • Ohhhh! Awesome - thank you so much! That totally solved the problem. I don't mind feeling like an idiot when the solution is so simple and effective. :)
Sign In or Register to comment.