in-text citation containing first name even if author disambiguation has been corrected

I am citing multiple papers from Edward McAuley in my thesis. I'm having the problem where the first name is displayed because Zotero thinks there are two different authors with the same last name.
I read on the forum and saw it might be caused by the fact the sometimes it was written as E. McAuley in some references and Edward McAuley in others. It was indeed the case so I fixed that and switched them all to Edward McAuley. All ''McAuley''s in my library are now written with ''Edward'' for first name. The same problem still occurs.
Anyone knows how to fix this other than manually changing everything in Word?
  • To be sure, did you refresh? Did you try to switch for another citation style then return to your original style?
  • Had tried refresh multiple times and it didn't work. However, just tried switching from APA to ASA and than back to APA and it worked! Thank you!
Sign In or Register to comment.