unable to save metadata to zotero

Since a recent update I can no longer capture metadata directly from Amazon to Zotero (5.0.66) using Firefox (66.03). The only option I'm now offered is downloading a snapshot.
I have tried reinstalling the connector and restarting but that did not help.
I also downloaded the latest connector for Safari and tried using that but again I do not get the blue book icon, only the grey.
Please can you help?
  • Thanks, I'd been through that list
    None of those apply.
    I now think I may have just been unlucky with the particular Amazon pages I tried and the fault lies in them not my installation!
    I found the the problem did not occur with all sites: it works fine with Google books but not with Amazon on those three books I tried (at random from what I'd been looking at lately). Since then however, I've tried looking at a few others and it does work (but still not for the three books I looked at before) so I think I must just have been very unlucky recently in picking Amazon pages for books for which the metadata was incomplete (I've occasionally found the odd case where even on Amazon I had to enter data manually but never before three on the trot.)
    Thanks for replying, anyway.
  • You can always copy the ISBN from the Amazon page and enter it into the Zotero magic-wand field.
  • Thanks, I'd been through that list
    Note that the page asks for more information at the end that you haven't provided. We'd need that to debug this further.
  • I have just noticed that Amazon URLs with a reference at the end show in my Zotero connector as a web page, while the same URL with the reference removed show in the connector as a book.

    https://www.amazon.com/gp/product/B00B9XTLJ8/ref=dbs_a_def_rwt_hsch_vapi_taft_p1_i9 = web page

    https://www.amazon.com/gp/product/B00B9XTLJ8 = book

    With more recent Zotero and Firefox on Win 10.
  • I'm not seeing that -- make sure to wait until the page is fully loaded.
Sign In or Register to comment.