Zotero can't start on Linux (KDE Neon) desktop after update; reinstall?; Zotero on laptop is OK

Since a Zotero update, Zotero can't start on my Linux (KDE Neon) desktop; Meanwhile Zotero on laptop under KDE Neon is OK.

Should I uninstall and reinstall?
Or, if you advise, I could try to start it from Zotero parts (which?) in my Downloads folder...

  • Yes, start it from the terminal to see whether you get any error message
  • Thanks, poettli,

    Well, I tried to start it by entering in the terminal
    It started fine.

    Starting from the launcher still fails.

    I right-clicked the Zotero entry in the Office section of the launcher and chose Edit.
    I found under Properties/Application/Command the string
    bash -c "$(dirname $(readlink -f %k))/zotero -url %U"
    I am not sure I am at the right spot or what to fix and how.
    Any ideas?
  • I have the same problem as jimmul7.
    Launching from terminal works fine (with or without the -url %U flag), but the launcher does not start the program and there is no error message.
  • It's possible your distro isn't fully implementing the .desktop spec, or is implementing it differently (e.g., passing a URI for %k instead of a file path, which would break the readlink command).

    You can try adding logger to the beginning of the Exec line and check your system log to see the exact full command that's being run after substitutions.

    (Or you can just hard-code the path in the Exec line, but to fix this for people on distros where it doesn't work we'd need to know what was going wrong.)
  • Thanks, dstillman.
    The hard-coded path worked, so I'll just keep it like this.
  • OK, but again, if you want to help us fix this for others, we'd need to know what was being called.
  • I use Ubuntu 19.04. I'm not sure if I followed exactly what you meant, but I changed the `Exec` line to:
    bash -c "echo $(dirname $(readlink -f %k))/zotero -url %U > /tmp/test_launcher.log"

    the log file contained the following:
    /usr/share/applications/zotero -url

    So apparently, something went wrong there. /usr/share/applications is simply the directory where the .desktop file is located.
  • It looks like you may have copied the .desktop file instead of symlinking it from the application directory (as the installation instructions say to do).
  • Yes, I'm pretty sure that's what caused the problem (it was a while ago).
Sign In or Register to comment.