Openoffice extension - no connection with firefox

  • Thanks Dan: I ought to have checked the forums more thoroughly before posting.
  • I found solution to this problem for XP users...

    Go to Control Panel-->Network and Internet Options-->Internet Options-->Click on Advance--> Click on Restore Advance settings.

    Start your word/Open office document and then Zotero should work fine.

    This had nothing to do with version of firefox or plugin long as they are compatible, zotero should work fine.

    So, basically its microsoft internet explorer settings which is creating all this problem..... :-) (restore all the advance settings).

    Hope this works for others as well....cheers....

  • I suspect i have the same trouble on my ubuntu machine (running 2.8 i think) and OO 2.4. When i try to do something that needs communication with firefox like inserting a citation OO just goes grey and freezes.

    On my EEE with the standard Xandros installation and OO 2.0 everything works perfectly though..

    Now im afraid of upgrading OO on my EEE, because i really need zotero working on at least one machine. Any advice?
  • This may help somebody:
    The open office plugin was working for me up until yesterday when I updated my open office to 3.0.1. It then stopped working and gave me the connection error.
    This was on: openSuse 11.1; OpenOffice 3.0.1; Firefox 3.0.6; Zotero 1.0.9; and plugin 1.0b4. I also tried Zotero 1.5 and the associated plugin.

    After downgrading back to open office it has started working again.
  • Hi,

    I'm having a problem with the Zotero extension for OOorg.3.0.1. (I've also tried with 3.0.0). When I try to insert a new citation in a new document, I receive the error: "An error occurred contacting Zotero. Please ensure Firefox is open and try again."

    When I go to the OO extension manager and check for updates, with the "show all updates" box checked, I receive a warning for "Zotero OpenOffice Integration" in the description: "An error occurred: Not Found!"

    I'm using:
    -MS Windows - Vista
    -firefox 3.0.7
    -Zotero 1.5 beta
    -Zotero openoffice integration 2.0a2.

    Up until recently, it worked perfectly. I first encountered the problem after I re-installed openoffice 3.0.1 (without uninstalling the plugins). I also installed some Vista updates.

    So far, I've searched this forum and the openoffice/word extension forum, and tried the troubleshooting tips there. I've reinstalled the extensions in both ff and oo. I've completely uninstalled oo and my profile and reinstalled a fresh version. I've checked my firewall settings and turned them off. I've run the ff debug console. I never use offline mode. I've restarted the computer. I've tried to uninstall zotero 1.5 and revert to 1.0, but it won't even allow me to open up the zotero pane (I understand that the library collection would be lost, and I'm okay with that). I'm not even sure that if I succeeded in reverting to 1.0 and the appropriate oo plugin whether that would fix my problem.

    Can anyone help?
  • Hi,

    I've experienced the same problems with OO 3.0.0 on PCLinuxOS 2009.1. It was working fine with OO 2.2 (under PCLinuxOS 2007), but has stopped working on the upgrade. I have tried both the newer Zotero (with sync) and the old version that was working fine under OO 2.2.

    When I go to install Zotero via the extensions manger I get the following error message ;

    "ImplementationRegistration::registerImplementation() - The service cannot be instantiated"

    I'm guessing this is similar to the OO 3.0 Python problem on the Macs with the newer Zotero version?


  • @phains

    I was just having the same problem. You need to install the PCLinuxOS-appropriate package for ''.
  • edited March 30, 2009
    I get the error message that everyone is describing in this forum, but only when my internet is disconnected.

    To test this: I disconnected my internet. Opened Firefox. I can browse/edit my entries, but when I try to use the plugin in OpenOffice I get - "An error occurred contacting Zotero. Please ensure Firefox is open and try again." Firefox is open when I do this.

    This is all fine for me because it everything works when I have an internet connection. I just thought posting this might give someone (with a little more know-how) a clue as to what was going on with the people who get the error message all of the the time.
  • edited April 21, 2009

    I am presently using the current Zotero openoffice extension with OpenOffice 3.0. Everything works perfectly such that I can insert citations and generate a bibliography. But the problem is that the citations inserted in the document are highlighted in grey. Can someone help with how I can sort this out. Thanks

    I later discovered that the printed document did not reflect the highlighted citations which is nice. However if the grey highlights can be removed it would be great.
  • Numa: Is this not field shading? You can disable that in OpenOffice by going to the menu 'View' and uncheck 'field shading'. Or alternatively use Cntrl+F8.
  • I have a problem with the openoffice extension. When I want to insert a citation there is an error: "An error occurred contactiong Zotero. Please ensure Firefox is open and try again."
    At this time Firefox is open.
    Operating System Windows Vista 64bit
    Firefox 3.0.12
    Zotero 2.0b6.3
    Sun Report Builder 1.1.0
    OpenOfice 3.1.0
    Zotero OpenOffice Integration 2.0a2
    Debug output:
    first: Integration HTTP server listening on
    than: Not initializing integration HTTP server

    I tried out almost everything but I can't solve this Problem.
    It would be very nice if sombody could help me.
  • klapdbmj: You see both of those messages about the HTTP server when you start up Zotero? If so, follow these steps to see if another program is bound to port 50001. If so, you'll need to either stop it or change the port used by Zotero and the plugin.

    You can change the port on the Zotero side by going to about:config in the Firefox address bar and changing extensions.zotero.integration.port to an unused port (say, 50009). You can change the port used by the plugin by editing the file within the OpenOffice data directory and replacing 50001 with the new port. Then restart both Firefox and OO.
  • Hello, I'm also having this problem -- however mine is taking place on a Mac. My zotero library is on a thumbdrive, and when I am adding/editing citations (etc) from my Windows XP PC (where I originally created the word files, library and citations) everything works fine. I only get the connection error when I try to move onto my Mac (OS X) -- it opens up the library without any problems, but I get the error message whenever I try to edit/add a citation.

    Advice in simple english would be greatly appreciated -- am trying really hard to follow this thread but am a luddite lost in the techspeak. Thank you!
  • good morning everybody!

    I've installed zotero extension in openoffice but it dosen't work. The message says that I have a problem+my firefox.

    what can I do?

    The version of zotero is 2 for firefox and openoffice.


    P.S. Sorry for my english : )
  • arodera: If you're receiving the message "An error occurred communicating with Zotero. Please ensure Firefox is open and try again.", see the troubleshooting steps.

    Completely rewritten versions of the word processor plugins will be released along with Zotero 2.0b7. They connect to Zotero in a new way that should avoid communication errors.
  • PROBLEM: 1320933215


    my problem continues. zotero doesn't work in openoffice. I am sure that I have the same version 2.0 in firefox and in openoffice. So what can I do? the problem seems to be with the connection between openoffice and firefox.

  • arodera: Wait for 2.0b7, which will be available soon.
  • Hi Dan,

    I have problems to get the OpenOffice plugin working on my system:

    Ubuntu 9.04
    OpenOffice 3.1.1
    Firefox 3.5.3 / Zotero 2.0b7.1 / Zotero OOIntegration 3.0a2 / Java 1.6.0_16
    I have set the following path for
    Java URE Directory: file:///usr/lib/jvm/java-6-sun/jre/bin/
    OpenOffice Executable Directory: file:///usr/bin/

    The plugins installed fine in Firefox, I do see the Zotero Toolbar in OpenOffice, but when I try to add a citation, I get the message:

    'Firefox could not load the component required to communicate with your word processor. Please ensure that the appropriate Firefox extension is installed, then try again.'

    Any guess what I did wrong?

    In addition to the info above, I just found out that in Open Office, the extension manager reports that Zotero OpenOffice Integration 3.0a1 is installed, while I used the 3.0a2 version in Firefox to automatically install the toolbar in OpenOffice.
    After a manual removal of the Zotero toolbar in OpenOffice using the extension manager, and a reinstall using the Firefox plugin, again OpenOffice reported that 3.0a1 has been installed.

    Any suggestions would be very welcome.
  • edited September 18, 2009

    Re: version number:
  • This thread is no longer relevant for Zotero 2.0b7 and later.

    All the information we have for the Zotero 1.0–era communication error is on the troubleshooting page. If none of the suggestions there work for you, consider upgrading to Zotero 2.0.

    This thread is now closed.
This discussion has been closed.