Zotero 2.0 hangs Firefox on first sync

Zotero (clean install) hangs Firefox for about 10 minutes when trying to sync for the first time. the same thing happens when I try to reset using the server data. Firefox is using 100% of one of the CPU cores all the time. There is some network activity that happens periodically every 40 seconds.

My lybrary has more than 700 entries.
My system is:
Linux x64 (Open Suse 11.1)
Firefox 3.0.10

The problem happens both with Zotero 2.0.b3 branch and the trunk.
  • There have been many reports like this in the past two days. I'm just guessing, but they seem to be related to a massive overload on the Zotero servers. See http://forums.zotero.org/discussion/6961/20b3-sync-error-processing-uploaded-data/#Item_0 for more background.
  • edited May 16, 2009
    I am also trying to do an initial sync on a new installation of firefox.
    (Windows Vista, Firefox 3, Zotero 2.03b).

    Firefox has been hanging for over an hour. I have a database of almost 1900 entries. What is a reasonable amount of time to expect zotero to complete such an operation?
  • I am also trying to do an initial sync (Mac OSX 10.5.6, Firefox 3, Zotero 2.03b). I just get an error message which says "empty response from server".

    Below is the report ID:


    What to do? I have about 800 entries.
  • Sync was successful first time around. But now I try to sync and I get an error saying it doesn't like my tags. So I deleted all my tags but it still won't sync and gives me the same error message. Hmmm.
    Anyone else come across this?
  • I second rishpai, but I'm running Ubuntu 9.4, FF3, and Z 2.03b. "empty response from server." I even deleted most of library and tried again - no luck.
  • Cannot get my Mac to Sync. Get "Last error: Empty response from server." Report ID: 1592453807

    PowerBook PPC OSX 10.4.11

    Tried it with 2.03b and mostly just hung in FF 3.0.10. Installed 2.04b and now runs (if I say ignore unresponsive script) but still gives me the same message.

    I did get it to work on my work PC with an older version of FF but that is a dummy account for now with only 2 records in it.

    I have 2 Mac laptops which have got slightly out of sync that have over a 1000 records. Please get this migration business worked out. I want the new features and to go back to loving Zotero.

    Will NOT attempt upgrading from 1.0.10 to 2.0x on my main machine until this is worked out.

  • The above problem laptop (PowerBook) has now synced. This made me hopeful enough to upgrade the MacBook to 2.0 but not syncing due to a different issue. :-(
  • 2.0b5 - sync error again - e33ced60.
  • I can confirm that I too have the same problem as original poster. The details:
    I'm on a computer that is not my regular system, so I wanted to install Zotero 2 to sync my citations to this machine. I have a large number of citations (5000+?).

    Running Ubuntu 9.04.
    Firefox 3.0.1.
    Yesterday I installed Zotero 2.0 b5.
    No problems with installation, no problems in Firefox up to that point.
    On first sync with Zotero server, firefox hangs. totally unresponsive.
    System monitor shows Firefox occupying 80% and up of CPU. Status: uniterruptible. Waiting channel: sync_page.
    Firefox also using massive amounts of memory, between 240-270 MB.
    After a few minutes this CPU usage settles down but memory usage remains above 240 MB.
    Network usage is at 0 with blips every 30 seconds.
    Firefox is not salvagable, only way out is to kill the process.
    restarting Firefox, no problems.
    Upon opening, Zotero gives an error message that says:

    "Another sync operation, started 34 minutes ago from the current IP address, is still in progress. This may indicate an active sync or may have been caused by an interrupted session.
    Do you want to reset the existing session? You should only do so if you do not believe another sync process is currently running."

    I answer cancel, and sync icon remains with exclamation point over it, no citations have been synced.
    Click sync icon, I get the same dialog about sync reset, click reset, and the whole Firefox freeze recurrs.

    I have not yet successfully synced and have no problems with Firefox unless I try to do so.
  • Hornblake: Run the sync with debug output enabled, and you'll be able to see if things are actually progressing. (Windows users should not attempt this due to an excruciatingly slow debug console.) 2.0 Beta isn't fully optimized, and the initial sync of 5,000 items might very well hang the Firefox UI for a while. Subsequent syncs should be instantaneous.
  • Right, I figured that out only after I posted. I ran from command line with debug "true" and it is still running, 6 hours later. At least I know it's syncing, but in the meantime it's eating all my RAM. I appreciate that the enormous number of items is going to take a while.

    Change my bug to -- "renders computer useless for the duration (hours) of sync".

    Thanks for the response -- looking forward to future versions, keep up the good work.
  • We've never seen a sync process take anywhere near that long. It's possible that the console on Linux slows things down. (It certainly doesn't slow things down as much as on Windows, but it could still be slower than without it. On OS X there's not really any difference.)
  • 1426669432

    Still not syncing after weeks of trying. Am on a 13" MacBook running OS 10.5. Started with 2.04b but upgraded to 2.05b a while ago.

    Please help as this is my main computer. Secondary (and dying) machine sync'd (see above) and work PC sync'd. But they don't really matter.
  • mlindner: See Troubleshooting Sync Errors and/or wait for the next beta build this weekend, which should offer an additional method for dealing with sync errors without clearing one side.
  • Report ID: 731912691

    Backed up library. Per instructions in link you provided I attempted the Full Sync with Zotero Server. Am running Zotero 2.0b6.4 on Firefox 3.5.2 on Mac OS X 10.5.8.

    I have 3 machines with Zotero on them. This one, which is my main machine and has some files not on the previously "abandoned" PowerBook mentioned above, the above PowerBook which synced long ago, and a PC at work.

    What do I do next? If looking at my library online is any indication then the files that are unique on here--not that I am sure which they all are--are not in the online library. These missing files are my newest work. Restore from Server certainly does not sound like what I want. Should I try Restore to/from Server on all of the machines? I am hesitant to try that because the PowerBook is barely running at all and I am afraid I will lose any data on it that is not in sync with this machine. Not sure how much that is.
  • Got it working with the newest upgrade last weekend.

    Things aren't perfect & am having trouble finding answers in the forums but I have my main computer synced now so it's progress.
  • What other problems are you having?
Sign In or Register to comment.