APA in-text citation with given and middle name appearing

As the title shows, when I use Zotero to make APA-style in-text citations, sometimes the given and middle names of the lead author appears.

Looking at older answers, it said Zotero does this to disambiguate between authors with same last names, but when I went through the references individually to make the names exactly the same, the first and middle names sometimes appear.
Also, in different citations but with the name lead authors, one citation will show both first and middle name while another will show just the first name, like the following:

(J. J. Arnett, 1994; J. Arnett, Offer, & Fine, 1997; Dahlen, Martin, Ragan, & Kuhlman, 2005; Jonah, 1997)

The Arnett author is the same person.

The only way I know how to fix this is to manually delete the first and middle names in the field. Is there a way to configure Zotero to do this automatically?
  • edited March 20, 2019
    Please verify that every time the name J. J. Arnett , J. Arnett, Jeff Arnett (or that of any other author) appears in your Zotero database that her/his name is entered exactly the same for each publication. Ideally you should edit the name so that, each time it is included in your library, it is entered as the most complete form: Jeffrey Jensen Arnett -- even if the name on a particular article is presented in a less complete form.

    Else, Zotero will not recognize the names as belonging to the same person and will disambiguate.
  • Thanks for the links, and as per the suggestion I've tried that. I've went through all the names and made sure the names are the same ("Jeffrey Jensen Arnett") but Zotero still displays it as the original comment.
  • Try in a new document, see if it works correctly there?
  • Thanks adamsmith, I've tried using the citations in a new document and it works properly (i.e. without the first and middle names).

    Is there a way to fix the citations in the old document, though?
  • Make sure you hit the refresh button. If that doesn't help, it may unfortunately require removing and re-inserting the citations in question -- they're likely no longer connected to the data in Zotero.
  • I've also had this problem, and the refresh button was also not working. The in-text citation were highlighted in grey when the cursor is positioned within the brackets, and I could edit the citation (remove and reenter the citations), so it seemed the citations were still attached. As a last stitched effort (while I was making a complaint here, of course), I quit Word and Zotero completely, then reopened and tried the refresh button again... Low and behold it worked.

    So, hopefully for you @mrkillercow (and future readers), quitting Word and Zotero, and maybe shutting down your computer, works.
  • Note that the grey shading means that the citations are still _recognized_ but not necessarily that they're still connected to the Zotero item. The only way to see that if to check if you have an "Open in my Library" button when trying to edit the item.

    @adomasven this keeps coming up. Are you considering some option to highlight&replace disconnected items?
Sign In or Register to comment.