Podcast Citation

Hi all I am trying to insert a podcast citation. I am noticing that when I add the citation in my word document neither the program number, date of the program or access date. How can I get this to be included?

Also, how can the panelists be displayed besides the host?
  • What style are you using?

    Also, the Date field was inadvertently left off for the Podcast item type. You can add it to Extra like this:
    Issued: 2010-11-30

    (note that dates should be entered in Year-Month-Day format)

    You should enter all names that you would want to include in the citation as a "Host" rather than as a "Guest" or other creator type.
  • Chicago/Turbian style.
  • I did the Issued and it only displays the Year not the full date for the citation and bibliography.
  • Pretty sure that's because of how the style is coded. Podcast doesn't have its own item type in CSL, so it's a bit tricky to navigate. You could try instead using radio broadcast, which I think should be displayed with full date.
  • The easiest way is to also add this to Extra:
    type: broadcast

    @adamsmith The problem is that podcast is mapped to CSL song instead of broadcast. This doesn’t make much conceptual sense to me, and it also produces the wrong output for Chicago, APA, and MLA (probably also others). I’ve suggested it should be remapped when fields are updated in Zotero.
  • Pretty sure the CSL mappigns aren't part of the database schema, so we can do this right now. @dstillman - would you take a PR/make that change?
  • Thank you all for your assistance. If there is anything that I need to do in relation to your changes please let me know.

  • @dstillman - would you take a PR/make that change?
    Sure. So we're just saying that https://github.com/zotero/zotero/blob/a92b29cebf7198687cb3884e5fe1c0441d456f0e/chrome/content/zotero/xpcom/utilities.js#L136 should be to "broadcast" instead?
  • Is there a bug report I can subscribe to for getting the Date field added to the Podcast Item Type? It would be great to have that fixed.
  • It'll come together with a whole swath of other changes to item types & fields, so you'll notice.
    (do see the workaround above though).
  • Do note that only adding `Issued: 2019-01-04` is necessary now. Adding `type: broadcast` isn't necessary anymore.
  • Any update on this issue? Seems that issued date added in extra is still required, so hoping for a fix soon.
  • Nothing new -- this will be in a major new version with significant changes/additions to available types and fields; there's no way you'll miss it when it arrives
  • Just to chime in on this - Since the last word on this was over 6 months ago, any progress on updating the style for podcasts? I am writing a book on podcasts and relying heavily on Zotero. So, I am ending up citing a *lot* of podcasts in this book. It would be really helpful to have this style updated to include the broadcast or release date of a particular podcast episode. Thank you to the entire Zotero team!
  • edited October 10, 2020
    What do you mean by “style”? Most styles will already include the date of the podcast if you enter it in Extra like this:
    Issued: 2020-10-31
  • By style I simply mean the built-in Item Type preferences for Zotero. Currently there is no "Date" field in Zotero when you select "Podcast" as the Item Type. This is what people have been asking for. Consequently, when you examine your references in the center, main Zotero window and have the Year column activated, a podcast reference does not appear to have a year in the column. I often filter my references by Year, and this is not possible with the "Podcast" Item Type.

    That being said, you are absolutely right that if you place the date within the Extra field as you suggest, when you select APA, MLA, Chicago, or another citation style, the year/date does appear within the citation within the document itself (just confirmed this).

    Nevertheless, all I am asking is that the Date field is added to the "podcast" Item Type such that the strategy/hack that you mentioned above is not needed.
  • edited October 11, 2020
    I'll try saying this one more time: There's really no need to keep bringing this up -- there is no one you need to convince. This will happen, it isn't a small change that can "just" be made, it won't happen any faster if more people ask, and it won't be a change that you miss when it occurs.

  • Apologies, @adamsmith! Didn't mean to be a pest, just wanted to add my voice to the requests. Didn't realize it wasn't a small change that could be made in a brief update to Zotero. Thank you for all of the great work on the project. My sincere gratitude.
  • I did just add import from Stitcher with pretty good metadata, though. I won't give you the host (because that's not on Stitcher in a standard format) but other things, including issued in the extra field, will make it.

    Should make it into your Zotero within 24hs
  • Terrific news, thank you so much, @adamsmith! I really appreciate all of your efforts on this invaluable project. Once the update makes its way to me, I'll test it out on some others like Overcast, Apple Podcasts, and Google Podcasts, too. On behalf of all of us writing about and citing podcasts, much thanks and gratitude.
  • I wouldn't expect much from any of the others in terms of metadata -- Stitcher has good metadata by default and ranks consistently high in web searches, so that made sense to me for import into Zotero.
    I don't think that's the case for the others (which is mostly unrelated to their quality as podcast apps)
  • The Date field still seems to be missing from the Podcast item type. True?
    I'm running Zotero 5.0.97-beta.51+6206209ed
  • (I did the workaround putting e.g. "Issued: 2019-08-20" in Extra, and that does work.)
  • @adamsmith it's now been over two years that people have been asking (on this thread; I've seen others going back to 2017) for the date field to appear automatically in Podcast item types. Any word on when it might be updated so we don't need to use the work-around?
  • @meira_levinson: Soon. No more specific answer than that.
  • OK, thanks @dstillman! Glad to have the work-around in the meantime...
Sign In or Register to comment.