Google Doc: citations converted to plain text

I have been working on a 30 page document with 100+ citations. At some point, some of the links for the citations got lost. The according entries in the bibliography are not there any more. I am now going through the document, checking each citation, and when it is "dead" (i.e. plain text), I add it with Zotero again. Very tiring and annoying. Any idea why that may have happened? I did not click "unlink", of course! And it is also not for all of the citations, just for some. Thanks for your help.
  • edited February 22, 2019
    I'm experiencing the same problem. Every now and then, seemingly random, links for citations disappear. The text is still there, but can not be refreshed by the Zotero plugin anymore.
    I'm not sure, but recently came to suspect cut & paste operations within the same docs document. I can reproduce this:
    - cut a quotation, including the Zotero footnote number
    - the quotation disappears, including the Zotero reference below the page
    - paste the quotation somewhere on the same page
    - the quotation is back, including a (perhaps different) footnote number; the correct Zotero reference is back (perhaps on a different line) below
    - try to edit the Zotero reference gives the error: "Zotero experienced an error updating your document. Selected field null not returned from Docs backend"
    - from now on, the reference is "dead": putting the cursor in it, does no longer give the edit with Zotero menu.
  • Cutting and pasting is currently not supported within Google Docs for citations and the most likely reason for your toubles. We're working to support it in the near future.
  • I understood this statement until now always as 'cutting and pasting between Google Docs documents', and not as 'cutting and pasting within the same document'. The latter would make the Google Docs integration of limited use for writing papers?
  • This was true initially, but we needed to make some changes to the plugin because large documents were failing to update and/or work completely. A side-effect of this change that we later realised was that copying within the document had been compromised. We are working to restore it.
  • Thank you for the clarification. Is there any timeframe for this update? Are we talking hours, days? Or weeks?
    In the latter case, and as there is also no way to export from Google to LibreOffice or Word preserving citation links, is there a way to revert to an older version of the plugin?
  • The Beta version should be out next week. There is currently no way to go from Google Docs to other word processors and preserve links. There is no way to revert back to an older version of the plugin, since part of it is deployed within Google Docs itself and global for everyone.
  • I'll go for the beta next week then. We will just have to stop cutting and pasting for a few days...
  • I am sorry to say that cutting and pasting is not the origin of this bug in my case. It happened somehow else, in passages that I edited and added new citations, some of the citations were working and others were not, even without any cutting and pasting.
  • @ppraet We have updated the Zotero Beta Connector with changes that fix copying of citations.

    @kjell.kuehne You should use the beta version of the connector too. It is likely that earlier edits were the cause of citations unlinking. There is no other way for citations to unlink when using Google Docs to write and edit normally.
  • I've installed the Beta Connector today, but I'm still experiencing the same behaviour. When I copy/paste a citation and then try to edit it again:
    "Zotero experienced an error updating your document.
    Selected field null not returned from Docs backend"
    After this, the zotero reference becomes plain text.
  • I've posted a Report ID: 1552541473
  • @ppraet After updating did you restart your browser? After you restart your browser you should make sure that you allow a google docs document is fully loaded before attempting to copy citations.
  • In the mean time, I have not only restarted my browser, but rebooted my complete PC. The behaviour is still the same, even with a small test document (two lines with two citations I try to swap position with cut/paste).

    The report ID for this latest test:
    Report ID: 391020355
  • I am testing on the same OS, same browser, same version and it works well for me. Could you create a screen capture of what you are doing? Insert 2 citations into a document from scratch and then cut the first one and paste after the second one.
  • How can I send you the screenshot? @adomasven
  • edited February 28, 2019
    You can either upload it somewhere (e.g., Dropbox) and provide a link here or, if you prefer to keep it private, email it to with a link to this thread.
  • Ah, sorry about that. The pasting functionality still wasn't working for footnotes. We have fixed that now. Make sure you are on the latest connector beta version and try again.
  • I'm sorry to say so, but the problem is still the same as it was. I've submitted a new Report ID: 6013551.
  • @adomasven could you please have another look at this problem?
  • edited March 4, 2019
    Please make sure you restart your browser after updating the plugin and try testing in a new document first. If it still doesn't work: what citation style are you using? How are you performing the cut-paste?
  • @adomasven, Not only did I restart my browser, but I rebooted the PC. I'm using the plugin 5.0.54beta4, and Chicago Manual Style 17th edition full note.
    I hope you can sort this out.
  • How are you performing the cut-paste operation? Are you using keyboard shortcuts or google docs menus?
  • Always with ctrl-C/ctrl-V. But to me this is a strange question, because when I try to use the edit menu, Google Doc always says: "These actions are unavailable using the edit menus, but you can still use ctrl-C, ctrl-V, ctrl-X."
    This has always been the case, as long as I remember using Google Docs, so I consider it normal.
    I'm using Ubuntu 18.04.2 LTS, 32-bit and Firefox 65.0.1 (32-bit)
  • Could you test cutting and pasting in a new document where you use the Chicago Manual author-date style? Does that work properly? What about if you insert author-date citations into footnotes that you create manually via google docs and then copy those?
  • edited March 5, 2019
    The behaviour is exactly the same with author-date style, in text or in footnotes. And I tried with a few other styles as well. Also changed the language of the style back to English instead of Nederlands.

    Just tried the same scenario on another PC (Ubuntu 14.04 LTS, 64-bit this time), with freshly installed Zotero, and still got the same error. Are you positive that you can not reproduce the error?
  • Yes, this works for us with 5.0.54beta4. Just to make sure we're all testing the same thing, could you provide the exact Steps to Reproduce in a new document?
  • @ppraet Open this clipboard test page in a new tab, then go to Google Docs and copy some text that includes a citation, go to the clipboard test tab, click your mouse on the lower right frame and perform a paste (ctrl-v). Some clipboard information will appear in the frame. Copy that information and save it in a github gist or a hastebin ( and paste the link here. Make sure you do the copying and pasting in the same firefox window.
  • @adomasven
    I first tried hastebin, but was unable to generate a URL. I don't have a github account so I tried with Pastebin. Hopefully this is OK?

    It is really straightforward.
    1. start a new google docs document
    2. Type a line of text, then add/edit citation from the Zotero menu, and add a citation. It does not matter which style, but I use Chicago Manual Style 17th edition full note
    3. Repeat step 2 on a new line
    4. Go back to the first line, select the text incuding the citation (in my case the footnote number) and use ctrl-X to cut
    5. Move the cursor below the second line (from step 3) and paste with Ctrl-V
    6. Now place the cursor inside the pasted citation (in my case that is in the footnote area); a small menu "edit with zotero" pops up. Click on it to edit
    7. An error message like "Selected field WunuB1 not returned from Docs backend"
  • After copying and pasting a working citation open the Developer Console (by pressing F12). Copy the contents of any error messages listed and provide another pastebin.
Sign In or Register to comment.