Exporting PDFs in RIS file

I'm having an issue where I want to export a Zotero collection with attached PDFs and import into Endnote. I select RIS as file type, and specify that attachments should be included. When imported into Endnote, I get a bunch of broken links. In the far right for any one citation, there is a note that says "the following file could not be opened...." and then it gives a path that is, for example, files/1988/Ulrich_1984. However, when I look at that PDF's location in Zotero, I get the path ...Zotero/storage/9H8VRP6N.

So there seems to be a disconnect between where Endnote thinks the PDFs are located and where Zotero does. Any ideas where this process might be going wrong, and how I might rectify? Thanks.
  • Well, Zotero would export the files into the same folder with the PDFs into a relative path, so that's the ones you're actually looking for. But I don't think Endnote understand the relative path, so you may have to do a search and replace for something like

    L1 - file/ --> L1 - [the full path of the RIS file]/file/
  • Thanks--is that generally the case with exporting RIS files from Zotero? I usually tell patrons that RIS exports from Zotero to Endnote or Mendeley (and visa versa) will also include any saved PDFs. But perhaps that is not true?
  • I think Mendeley puts absolute paths into RIS, so Mendeley --> Zotero will just work. Endnote to Zotero requires the RIS file to be in the Endnote folder, see https://www.zotero.org/support/kb/importing_records_from_endnote

    Zotero to Endnote is generally the above, i.e. requires tweaking to import. I thought this used to work, but it doesn't currently. Not sure about Zotero to Mendeley -- same there, I'm pretty sure this used to work, but not sure about the ability of Mendeley to understand relative paths.
  • edited March 2, 2019
    I would like to ask for advice concerning export from Zotero to Mendeley (I apologise if I missed this in another discussion). I use Zotero, but a colleague of mine asked me to export a list of references to Mendeley. I followed the instructions and exported the relevant folder using RIS. My problem is that attached files are not imported to Mendeley. This is not changed even if I try to import individual items from the list separately. I would be grateful for any help with this.

    System: 4.18.0-15-generic #16~18.04.1-Ubuntu SMP Thu Feb 7 14:06:04 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
    Reference managers: Zotero 5.0.60, Mendeley Desktop 1.19.3
  • > My problem is that attached files are not imported to Mendeley.

    Can you share the RIS for a single item? Zotero generally exports as cleanly as possible, so it might be a question of whether Mendeley can be slightly more permissive on import or whether you need to tweak the RIS to work around their limitations.

    Generally: there is no universally supported method of file links in RIS that will work with every program out there. There are slightly different methods of using relative links that are popular and even absolute links have challenges (changing if you move to another machine; not working at all in some programs).

    Mendeley and Zotero can exchange references using formats other than RIS & they may have better support for one of those other options.
  • edited March 2, 2019
    L1 - files/4899/Kahneman_Tversky_1979_Prospect Theory.pdf

    Zotero is exporting reasonable relative links that are similar to those exported by EndNote. It may be that Mendeley does not support importing files at relative links. You'd need to check with their support regarding the format they expect. This will likely be one or more of four options, but I don't use or support their tool:
    • Mendeley may not import any linked files in RIS
    • Mendeley may expect this in some entry other than L1 (the RIS format has changed over the years) & you'll have to find/replace that in a text editor
    • Mendeley may expect direct links, e.g. C:\temp\files\4899\Kahneman_Tversky_1979_Prospect Theory.pdf...again find/replace will help
    • Mendeley may expect full URIs, e.g. file://C:\temp\files\4899\Kahneman_Tversky_1979_Prospect Theory.pdf
  • edited March 9, 2019
    Thank you again for navigating me through this. Both your suggestions have worked.

    Edit (2019-03-09): Use the full URI only, Mendeley seems to 'forget' direct links, once the desktop app is closed (in the case I tested, it managed to remember only 2 out of about 30).

    For those on Linux, the path should look like this:

    L1 - /home/user/.../exportedfoldername/files/numericfoldername/filename.* [direct link]
    Edit (2019-03-09): Unreliable, see above.

    L1 - file:/home/user/.../exportedfoldername/files/numericfoldername/filename.* [full URI]

    Is there any way how to alter all the exported files en bloc?
  • just do a search & replace in the RIS file:

    L1 - files/ --> L1 - file:/home/user/.../exportedfoldername/files/
  • edited March 2, 2019
    Thank you for a prompt reply. It has worked. It seems to me, nevertheless, it is better to replace only "files/", as there are also L2- and L4-entries...

    I understand it is not a priority, but if this could be addressed some time in the future updates, I would appreciate it very much. Zotero will remain my primary reference manager, but when working with others it is not always possible to 'convert' them.
  • There's no reasonable way to fix this for Zotero: If you send someone else data, their absolute filepaths are going to be different, so relative paths of the kind used by Zotero are the only way to make file transfer between different computers work. The fact that Mendeley doesn't support that is really outside Zotero's control.

  • edited March 9, 2019
    Thank you for your reply. Excuse me if I ask a silly question, but would it not be possible to change the export script in such a way that Ln-entries were generated based on the export folder name? I.e.:

    Ln - ~/exportedfoldername/files/numericfoldername/filename.* [direct link]
    Edit (2019-03-09): Unreliable, see above.

    Ln - file:~/exportedfoldername/files/numericfoldername/filename.* [full URI]
  • But that only works on *nix machines and only if you place the exported folder in the home directory, so that's not really a solution. I think it'd be technically feasible (although I'm not actually sure -- it might be that the folder name is provided after the RIS file content is written).
  • Yes, that also crossed my mind... Or would it be possible to prompt user to enter the path manually as an export function is called?
Sign In or Register to comment.