Missing Items in my Library

Hello - I have used Zotero for a few years now, mostly for my PhD thesis which i finished last year. It took me a while to get back into writing of course, and now I am writing an article so I opened Zotero for the first time in several months.

It seems that a number of my Library items are missing. I know this for a fact, because Zotero produced my thesis bibliography...and items listed in that bibliography no longer seem to exist in my Library today!

Naturally, I have hundreds if not thousands of sources and so I am extremely alarmed - if the couple of items I happen to be looking for today are missing, how many more might also be missing! The prospect of going through them all manually is daunting as this would take several days if not weeks and I do not have time for this.

Has anyone else experienced a similar problem of disappearing item entries/sources?

Yes I have updated my Zotero; I have also accessed it not through standalone but through a brower and the situation is the same.

Anyone have any thoughts/tips/suggestions/help?
  • I have just selected one thesis chapter and attempted to search for the first ten items cited in that chapter - almost all of them no longer exist. why is this happening? Help me Zotero! can you please do something to recover this lost information asap? I am becoming increasingly alarmed :(
  • I've filed an error report (587308099) - there is something clearly very wrong here - my Zotero library appears to be from like early 2015 or something - basically all my late 2015/2016 work seems to be gone.

    I've always had 'automatic syncing' selected in my preferences, etc. Why has this happened? More importantly, how can we fix it?

    It's Sunday of course, but if someone could kindly tell me something tomorrow Monday 6 Feb I'd be super grateful. thanks
  • Have you used multiple computers in the course of writing the thesis? Are you looking at your library on a computer or online? Are you currently on the computer on which you wrote (at least some of) the chatpers(s) in question?
  • Greetings. I have the exact same problem. All the bibliography of the third chapter of my dissertation is now mysteriously gone. To answer adamsmith's questions:

    1. Yes, I've used multiple computers. But they are all personal and have my username synced in Zotero.
    2. I'm looking at my library both in my computer and online.
    3. No, I'm not in that computer anymore.

    Thanks. I'm also alarmed. Difference being that I haven't handed in my dissertation yet!
  • PD: In further look, I'm also missing many bibliographic items from the 1st and 2nd chapter too :(
  • Thanks, dstillman! I'll have to check all this after holidays in my office computer. Though I have my doubts it'll work because I don't recall opening multiple Zotero accounts, nor have I received any notification that the program is not syncing. And I just sold the computer in which I mostly wrote the chapters :( I might need to follow the "further troubleshooting" step.
  • Greetings. So sorry for the delay. I have checked in my office computer and it doesn't have the bibliography I'm missing. Could it be that (for some mysterious reason) Zotero was not syncing in my personal computer for a year or so (the time it took me to write the first three chapters) and I didn't notice it? Then I sold my personal computer, reseted the OS and lost all my data in Zotero -- could this be so?

    I'm no understanding the "further troubleshooting" section in the link dstillman shared. Not sure what a debug ID is and what is it for...

  • Could it be that (for some mysterious reason) Zotero was not syncing in my personal computer for a year or so (the time it took me to write the first three chapters) and I didn't notice it?
    Yes, I'm afraid that's the most likely reason. Zotero shows an error icon next to the sync button when a sync doesn't go through, but it's possible to miss it. (We're planning to make it clearer when syncs are failing.)

    What was the time period you're referring to, though, and were you making changes to other collections (but not the collection in question) on your office computer at the same time?
  • Yes, would be great if you could make a more salient notification when the sync is failing.

    I would say all 2018 and maybe half a year back (that is, second half of 2017). I couldn't say if I did changes to other collections, but it's quite possible. I also can't say what changes did I make in my office computer to my dissertation during that time. I would say that, if I did changes, these were minimal and that's why I couldn't notice the syncs were failing. I worked mostly in my personal computer.

    Would be such a great news if something can be made!
  • Hmm, well, the reason I ask is that you definitely have items — a little over 60 — created and uploaded all throughout 2018. And you have 5 collections created in 2018.

    I'm not sure how that squares with what you're expecting to see.
  • edited March 2, 2019
    That's good news, I guess. The fourth chapter, which I worked on from September to December 2018 seems quite synced in its bibliography. The third chapter (which I made from May to August 2018) has many references made with Zotero that I cannot find them in Zotero anymore. Take for example:

    Derrida, Jacques. 1992. “Given Time: The Time of the King.” Translated by Peggy Kamuf. Critical Inquiry 18 (2): 161–87. https://doi.org/10.1086/448629.

    Sutherland, Stuart. 2007. Irrationality: The Enemy Within. 21st ed. London: Pinter & Martin.

    Wittgenstein, Ludwig. 2009. Philosophical Investigations. Edited by P. M. S Hacker and Joachim Schulte. Oxford, UK: Wiley-Blackwell.

    Gilboa, Itzhak. 2012. Rational Choice. Cambridge, MA: MIT Press.

    Not sure how this squares either. Maybe the new collections I made in my office computer? Is there any way out of this? Thanks so much
  • Yeah, those items don't exist now. It does look like there were several batches of items deleted throughout the year, including on December 10, but a collection wasn't deleted at the same time. I'd guess that, as you say, you simply did the newer ones from your office computer.
  • (I assume you don't have a backup of the Zotero data directory on your personal computer from anytime last year?)
Sign In or Register to comment.