Debugged a Word Doc after receiving error message from Word on Mac 'CSL error'

Hi, I was asked via the Zotero Twitter account to post this on the forum. Apologies if this error has already been posted about etc.

I am running Zotero v.5.0.60 on Mac, using Word v.16.17.

I copied and pasted some text with Zotero citations from one word doc into another doc which also had Zotero citations and I got an error message (CSL error) when trying to add or edit citations to the pasted text.

The solution seems to have been to copy and paste the entire text (of the doc I added further text to) into a new document. I can now edit and add citations again.

I haven't tried to copy and paste any further text, so I wonder if the issue will happen again but at least I have a solution now - I hope!
  • Report ID: 693009789

    I received a similar CSL error. I did try copying the text and pasted into new Doc, it worked when I created my first citation, but after I attempted to add more citations the same CSL error popped.

    I am running Zotero v.5.0.61 on MacOS Mojave on Word v.16.21

    The error message reads:

    "Zotero experienced an error updating your document.
    CSL error
    is undefined
    at array citationsPost index 0, from citation
    at document position 0"

    Any help will be appreciated.
  • Restart Zotero. If that doesn't help, revert to non-Beta version of Zotero.
Sign In or Register to comment.