Unable to add citation in google document

edited February 7, 2019
For a google document with already ~20 citations included, I am no more able to add new ones.
After waiting few minutes, this is the message I get:
Zotero experienced an error updating your document.

Too many changes applied before saving document. Please save changes in smaller batches using Document.saveAndClose(), then reopen the document with Document.openById().

I updated zotero connector to beta to see if it would solve the problem but no.

My Debug ID is D1672588793.
  • How big is the document itself? How long ago did you add the previous citations? Can you produce a Debug ID from the Zotero Connector?
  • The document is 20 pages long and we have not been able to add citations for several months. I produced this Debug ID with Zotero Connector: D1196851234

    I finally solved the problem by:
    - removing everything in the document
    - adding a new citation
    - canceling the remove
  • That method seems to have worked but I have to redo all references.
Sign In or Register to comment.