Zotero Browser Extension in Chrome and EBSCO database searching

I've discovered a problem with the Zotero browser extension in Chrome and EBSCO searching. When the Zotero extension is enabled in Chrome and a user attempts to search in an EBSCO database such as Academic Search Complete, it appears to ignore keywords entered and any search criteria set resulting in a search of over 19,000,000 results. Additionally, you cannot open an article record or open a pdf full-text. I have confirmed that is is the Zotero extension causing the problem by only enabling this extension and then disabling it (so no extensions at all are present in Chrome) and the problem goes away. Furthermore, enabling other non-Zotero extensions does not result in this issue occurring. Here is a link to a video I recorded for EBSCO detailing the problem: https://drive.google.com/file/d/1QiJ9F6UAKL5s3VweaGWPBBy0polkoKqI/view

I'd appreciate any insight or help people can provide. Is this something Zotero developers can look into?

  • Certainly not a general issue with EBSCO and Zotero (not happening for me, e.g.). The Zotero connector is also really lightweight and should have absolutely no impact on how pages load/search and I'm not aware of any other reports of this.

    Can you replicate this on a different machine? It's certainly _possible_ this is due to Zotero and you seem to have done due diligence on checking that it is, but given how weird this is, troubleshooting is going to be a mess and we'd want to make absolutely sure before spending too much time on it.
  • Thanks for your response. I tried adding this to a new computer (a PC, I use a Mac) and you're right searching in an EBSCO database worked fine even with the Zotero extension enabled. I went back to my computer and completely removed the Zotero extension from my Chrome, then went to the Zotero website and reinstalled the Zotero/Chrome connector. That seems to have done the trick! I've had the connector enabled for a long time, so perhaps I just need to update it. All appears to be working now. Thanks!
Sign In or Register to comment.