Zotero-Google Docs integration - no popup window

From the instructions I understood that a popup window should appear suggesting me a citation to insert, but it does not. The text cursor stops blinking and I whatever I type does not appear on the screen, and that's it (I can left click on the page to continue writing).

Tried it on Chrome first : logged into my Google account, but the window does not appear. Plus Ctrl+Alt+C does not even make the text cursor stop blinking.
Preferences window does not appear either.
Same thing on Firefox.

I don't know if the connector debugging does anything in this case, but I submitted anyway (D1292999693).

Would be extremely thankful for fixing this - as it is much more convenient than the old way (through LibreOffice).
  • Restart Zotero and your Browser. When you initiate citing with Zotero from Google Docs, what is probably happening is that the Zotero citing dialog appears under the browser window and you need to use Start/bottom toolbar to cycle through Zotero windows to find it.
  • Thanks, you're right! It takes some time to load and show the window. But at least now it works fine.
Sign In or Register to comment.