Missing permissions in Word 2016 add-in

edited February 7, 2019
Hello,
I recently downloaded Zotero but am having trouble using the Word add-in. When I try to add a citation in Word, I get the "Missing Permissions" dialog box. I tried to follow the directions (check the microsoft word checkbox under "automation" in systems preferences) but when I go to that menu, the automation box is blank. I have never been asked to give terminal.app to control Word, as described here: https://www.zotero.org/support/kb/mac_word_permissions_missing. I have updated my Mac OS, Word, and Zotero to make sure I'm using the latest versions, but no luck. I'm using MacOS Mojave version 10.14.3, MS Word version 16.21, and Zotero version 5.0.60.

If anyone has any pointers I'd appreciate it.
  • Start by restarting your computer. If that doesn't help (this is not usually the advice we give), try downloading Zotero again and put it under /Applications with a different name, like Zotero_test.app. Restart Word, start the Zotero app with a different name and see if you get the prompt for permissions.
  • I tried downloading Zotero again under a different name, but when I opened the new app I still don't get the prompt, and I still get the same Missing Permissions error message when I try to add a citation in Word.
  • Me too! I get missing permissions also when trying to add a citation and have done all steps advised..... but no luck.
    Help! am trying to work on my thesis......
  • Check if you have any pending macOS updates first. If it doesn't work after updating or if you have no updates open a new document in Word, then open the Terminal application, paste

    osascript -e 'tell application "Microsoft Word" to insert text "hello" at the end of text object of active document'

    into it, press enter and see whether you get a prompt for permissions, and whether the text "hello" shows up in the document.
  • edited January 30, 2019
    Tried the script from above but still no luck.
    Is this a Mojave issue or an issue with Zotero?
  • What happened when you ran that, exactly?
  • 37:101: execution error: Not authorized to send Apple events to Microsoft Word.
  • It is a Mojave issue. The OS is supposed to display the prompt to request permissions when Zotero tries to control Word, or when running this script from the terminal. Instead it is instantly denying them. You can try creating a new user account on the computer and seeing whether it works there, otherwise you should look for support from Apple. The terminal command above failing without prompt is a good troubleshooting starting point.
  • @iadatto Just to confirm what exact version of Mojave are you running?
  • macOS Mojave v. 10.14.1
  • edited January 31, 2019
    You need to make sure macOS is fully updated to 10.14.3
  • Just updated and still no programs listed in the Privacy setting under Automation
    Very frustrating
  • And you do not get a prompt to enable permissions when using the Zotero Word plugin or with the terminal command above?
  • exactly, nothing
  • still not working on my end

    running Microsoft Word for Mac 2016
    v. 16.16.6
    no updates available
  • @iadatto Just to note, yours is not a Zotero, but macOS issue, so a fix from Zotero won't come. You will need to seek customer support from Apple.
  • A bit more explanation for the people experiencing this:

    Apple added security protections in Mojave to try to prevent apps (like Zotero) from interacting with other apps (like Word) without permission by prompting when an app tried to do so. Unfortunately, the feature has been very buggy and sometimes doesn't show the expected prompts. Apple seems to have fixed most of the cases of that by 10.14.2, but it seems to still not be working right for some people.

    If you open a new document in Word, open Terminal via Spotlight, paste in

    osascript -e 'tell application "Microsoft Word" to insert text "hello" at the end of text object of active document'

    and press Return, you should see a prompt from macOS about allowing Terminal to control Microsoft Word (the first time you try), and then "hello" should appear in your document.

    If that doesn't happen, and you also don't see an entry for Terminal with Microsoft Word below it in System Preferences → Security & Privacy → Automation, something isn't working right on your system. Importantly, this isn't a problem in Zotero, because Zotero isn't even involved in the command that you're running, which is simply testing Terminal's ability to control Word.

    A separate issue is that some apps need to be updated to work with this new Mojave behavior. If you're running Word 2011, you need to be running the latest version, 14.7.7, or else the above command (and Zotero integration) won't work. If you're running an outdated version of Word 2016, you'll need to upgrade that as well.

    But if you're running the latest version of Word 2016 or 2019, this command should work, and does for most people, so if it's not working for you, you should report that to Apple. (We can't reproduce this, so we're not able to report it.) If you do report this, I'd recommend mostly leaving Zotero out of it, because, as I explained, Zotero isn't involved in any way when running this test command. Unfortunately there's nothing we can fix in Zotero when this interaction is broken more generally on your system.

    You can also try in another user account to see if it works there.
  • Hello, I'm really glad this thread is listing my exact problem. I am having the same issue with the Accessibility screen not showing the Word app in the control field. If I log in as another user, I get no issues and Zotero works just fine. The terminal command gave me "37:101: Not authorized to send Apple Events to Microsoft Word. (-1743). So, since the app works in another profile without issue, is there a preference file in the bad account that I can trash and rebuild? The users account is not something I can trash and create new. My professor has years of data on this machine.
  • So, since the app works in another profile without issue, is there a preference file in the bad account that I can trash and rebuild?
    Certainly, but we're not sure what, and this is a macOS bug, which is why we suggest asking Apple.

    The one thing we can suggest is opening Terminal and running tccutil reset AppleEvents, and then restarting Zotero and Word and trying again (or restarting Terminal and Word and trying the command Adomas gives above). tccutil reset AppleEvents is meant to clear the entries under Automation and could potentially fix whatever's causing this, but as far as we know this hasn't actually worked for anyone.
  • Im having the same problem and can no longer use Zotero with Word 2016 v16.24. I have followed the instructions in Security and Privacy. Is it possible to prompt the OS to add Zotero's permission at the command line?
  • @Layntjie: Everything we know about this is explained in my two messages above. Make sure you're running 10.14.14, and see my messages above.
  • Thanks. I tried the 'osascript' was prompted to allow terminal to control word but the Zotero problem remains. I also did the reset command and it wiped out all automation permissions but still it does not work.
Sign In or Register to comment.