Advanced Search: problem with multiple filters

I realize that i can't add more than 2 multiples filters in an advanced search, whether I'm creating a new one or editing a saved search. I mean if click on the + after the second line nothing happens. However, I was able to do that until a few months ago..
Did I miss some latest changes?
  • That would be a bug and certainly not on purpose -- I also can't replicate it. Which Zotero version, which OS, have you tried restarting, have you tried with all add-ons disabled? A debug ID for creating an advanced search might help, too.
  • I can confirm this bug. Strangely, it seems to appear depending on the search fields specified in Advanced Search. But let's start from the beginning:

    My OS is Mageia Linux 6, my Zotero version is 5.0.59, and the only add-on is the LibreOffice integration (which is essential for me, so I'm not disabling it).

    I open the Advanced Search dialogue. By default, Title is specified as the search field. If I click the + sign near the right margin, a new line appears to permit the creation of a new search condition. This is as expected. It also works when I change the search field from Title to any of the others in the drop-down menu (Attachment Content, Attachment File Type, Child Note, Collection, Creator, Date, Date Added, Date Modified, Item Type, Note, Publication, Tag, Title - I'm spelling this out in so much detail because I don't know if it's the same across platforms).

    However, when I select a search field from the overflow menu (under "More"), the bug happens. Clicking on the + sign has no effect, a new row is not added to the search conditions. I haven't tried this with all search fields under "More" because there are so many. But the behaviour is consistent among all the ones I've tried so far.

    Incidentally, I often want to search in the Abstract. So I'd appreciate to have Abstract in the main drop-down menu rather than under "More", or to have this customisable in some way.

    I hope this helps!
  • Yes, that I'm seeing too (on Windows 10), thanks for the detailed steps to reproduce. cc @dstillman
  • edited January 4, 2019
    I am also on Windows 10, my Zotero Version is 5.0.59 and the behaviour is the same as described by DNigbur, you can add lines till you use the usual fields but it stops adding when you chose one of the 'more' fields. Same thing if you're editing a search which contain a 'more' field. But if you modify this latter and choose one of the main fields, you can again add new lines.

    I have a previous version installed (5.0.34) on the same PC, and with that version there is no bug.

    the Debug ID for editing a saved search is: D521029758
    the Debug ID for creating a new search is: D1028830634
  • Thanks for reporting this. This is a regression in 5.0.59, now fixed in the latest Zotero beta. The fix will be included in 5.0.60.

    (As a workaround, you can just click the + on one of the rows with non-More conditions — you don't have to click the bottom row.)
  • Thanks for the workaround.
Sign In or Register to comment.