EBSCO no longer saving pdf

We have begun having trouble saving PDFs from EBSCO databases. The Zotero translator popup has a red X next to EBSCO full text. We've tried in Firefox and Chrome on two different Macs.

One example is trying to save this article: http://ezproxy2.library.drexel.edu/login?url=http://search.ebscohost.com/login.aspx?direct=true&db=aft&AN=119971946&site=ehost-live

The Debug ID is D1318108447.

  • edited October 19, 2018
    For attachment-saving problems we'd need to see a Debug ID from Zotero rather than the connector.
  • Thanks. Here's the Zotero Report ID: 1255673740
  • No, you misunderstood -- dstillman still wanted a debug ID, but you need to create it from Zotero (standalone), not from the browser. See the linked instructions.
  • Sorry, That last number was from standalone, not the browser, but I guess was a report ID not a debug ID. Having Report Errors and Debug Output Options right next to each other in the menu may have confused me.

    Here's the Debug ID: D200493478
  • @dstillman could you take a look?
  • @milliken did this used to work before and has stopped working abruptly? Can you manually download this PDF from the database, because Zotero is pulling in a HTML file with a 404 error for the PDF link?
  • Yes, I think it worked until until sometime last week, or at least we hadn't noticed any problems (and none had been reported to us) until one of our librarians was showing a student how she could use Zotero, and the articles they were looking at didn't work.

    Here's another article, only this one goes to (I presume) an author's manuscript in an IR after the EBSCO download fails. http://ezproxy2.library.drexel.edu/login?url=http://search.ebscohost.com/login.aspx?direct=true&db=hjh&AN=112084194&site=ehost-live
    Debug ID for this article is: D1572568445
  • And you can confirm that manually downloading the PDF still works?
    It doesn't look like I have access to the databases you're trying this on on EBSCO. Could you try if the PDF downloads here?
  • yes, the manual download works fine. It does open first into the pdf viewer page but you can download from there. I'll see if I can find an example from another EBSCO database to try too.
  • OK, that exact PDF works for me, so this is a good one to troubleshoot. Could we get another debug ID from Zotero for importing that one and could you also please post the URL exactly as you see it (I won't be able to access anything with that, but it might show us what's different)?
  • I'm not really sure what's going on here — the same PDF works for me as well, and the debug output looks identical up to the 404.

    @adomasven, the only thing I can think of is that it looks like we're saving the wrong URL to the URL field — we're saving the proxy login page. That happens for me as well and the file still saves, but it's possible that the Drexel proxy is more strict about the right referrer being used.
  • The URL is wrong, but that's a translator problem @adamsmith? I agree that Drexel proxy might be more strict and deny the PDF because of wrong referrer.
  • It looks like EBSCO puts that URL in the RIS, which is where we're getting it.

    @milliken: If you click through to the PDF in the browser and then copy the URL to a new tab and try to load it there, does it work?
  • Opening the pdf does work in a new tab in the same browser. Using the same url in a different browser doesn't. Trying to add with Zotero from that new tab still fails.
  • What is a debug ID and has anyone figured out a solution to this?
  • edited November 29, 2018
    Instructions for providing a Debug ID are linked above (and here). We'd want a Debug ID from Zotero for a save attempt where the PDF isn't downloaded.
  • Listen you have got a lot of people all telling you the same things. I would think that you would be real clear about it already, no? Don't you clearly know by now that EBSCO is making it difficult to use Zotero? It seems from what I see hear that you would.
  • PDFs in EBSCO are working for us, and we've only had a few reports of this problem, so if it's not working for you we need more basic troubleshooting information to figure out why. If you don't want to provide what we're asking for, there's no need for you to post to these forums, and further posts of yours will be deleted.
  • First of all, one might not know exactly how to do that. Secondly, I went to the bug link and I felt it was complicated and was not sure what to do. EBSCO seems to run some school libraries it is the background of Northcentral University's library and they are set up to use Refworks. I am not sure how to do what you want and there seems to be several options in the bug reports, and I am not a techie person. I have done the best I can. This is what it says when it does not work: Monitoring prediction errors facilitates cognition in action (that was the title of the article and then)
    X EBSCO Full Text (in red). It does this with any PDF in EBSCO.
  • The page we linked to provides precise, step-by-step directions for providing a Debug ID. We need that to help you further. If you're having trouble with the instructions, you'll need to either explain what you're confused about or ask someone (e.g., at your library) to help you.
  • My school's library does not support Zotero because of the EBSCO situation and I am way older than probably have the people you deal with, have gone to 3 universities and worked in admissions for two colleges. First off, you need your debug instructions to open in a separate page, 2nd the instructions and what I see are different, but I figured it out, so I had to do things twice to get it right and the report is sent in....what is expressed by that report has happened a hundred times over when something is in EBSCO as an article and here is the ID D622517939 ...I am not going any further with this.
  • In other words, ball is in your court....fix or not, but I will putting up the end results in our library community, which has 9,000 students who I want to protect from this craziness between RefWorks, Zotero and EBSCO
  • edited December 23, 2018
    Bobbi Pauling: I'm not sure what you think you're accomplishing with your tone here, but it's not appropriate or helpful. We're trying to debug this, but since we can't reproduce it ourselves, we need people to work with us to do so. If you can't do that in a calm, civil manner like everyone else in these forums, don't post here.

    If someone's library wants to help us resolve this, they can reach out to support@zotero.org and provide us with a temporary test account for the proxy, and we should be able to fix it quickly.

    Otherwise, @milliken (or anyone else), if you're still experiencing this and don't mind following some unusually technical troubleshooting steps, could you try the following? (This is vastly more complicated than usual Zotero debugging, and I apologize for that, but this is a particularly difficult problem to fix without access to an affected proxy.)

    1) When viewing an article page in EBSCO, open the JavaScript Console in your browser (Cmd-Option-I in Chrome and Firefox) and switch to the Network tab.

    2) View the PDF in your browser. You should see a bunch of lines in the Network tab. Look for one that starts with "ContentServer.asp". Right-click on that one and click Copy → Copy as cURL.

    3a) If you're using macOS, open Terminal via Spotlight.

    On Linux, open a terminal the normal way.

    On Windows, if you have Cygwin, you can use that. Alternatively, you can use cmd.exe, but you'll need to download cURL for Windows, unzip it, and then drag bin\curl.exe to the command prompt window. Then press spacebar. When you then paste the command in the next step, there'll be an extra 'curl' at the beginning of the pasted content that you'll need to remove, since curl.exe is already there. You can use Ctrl + arrow keys to move quickly through the command line. (You can theoretically copy a PowerShell command from Chrome instead if you know what you're doing, but I don't know the details of that.)

    3b) In your terminal or command prompt, paste in the command. You'll see something like this:

    curl 'http://content.ebscohost.com.ezproxy2.library.drexel.edu/ContentServer.asp?T=P…' -H 'Connection: keep-alive' -H 'Cache-Control: max-age=0' -H 'Upgrade-Insecure-Requests: 1' -H 'User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/70.0.3538.102 Safari/537.36' -H 'Accept: text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,image/apng,*/*;q=0.8' -H 'Accept-Encoding: gzip, deflate' -H 'Accept-Language: en-US,en;q=0.9' -H 'Cookie: ezproxy=abcdefg' -H 'If-Modified-Since: Wed, 28 Nov 2018 17:42:25 GMT' --compressed

    To explain, this is a command that performs web requests ('curl'), a URL ('http://content.ebscohost.com…'), and a series of "headers" that are sent with web requests (-H 'Cookie: ezproxy=…'). The goal here is to figure out which headers are necessary for the PDF request to work through your proxy. For us, only the Cookie header is necessary.

    4) Delete from the end of the line until you get to the end of the "Cookie" header, making sure you leave the single quote at the end of it. (In other words, remove -H 'If-Modified-Since: … GMT' and --compressed.) Then add | grep -E '%PDF|H1' to the end of the line. (That vertical line is a pipe character — i.e., shift-backslash.) You should see something like this:

    curl 'http://content.ebscohost.com.ezproxy2.library.drexel.edu/ContentServer.asp?T=P…' -H 'Connection: keep-alive' -H 'Cache-Control: max-age=0' -H 'Upgrade-Insecure-Requests: 1' -H 'User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/70.0.3538.102 Safari/537.36' -H 'Accept: text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,image/apng,*/*;q=0.8' -H 'Accept-Encoding: gzip, deflate' -H 'Accept-Language: en-US,en;q=0.9' -H 'Cookie: ezproxy=abcdefgh' | grep -E '%PDF|H1'

    If you then press Return, you should see either "Binary file (standard input) matches" (which means it was able to access the PDF) or "<H1>404 Not found</H1>" (which means it wasn't). If it says "404 Not found" already or the command doesn't return anything, stop there and let us know.

    5) Try removing additional headers — -H and the entry after it — until it stops saying "Binary file (standard input) matches", leaving in -H 'Cookie: ezproxy=…' (since it definitely won't work without that one). Make a note of which header you're removing. Again, the goal is to figure out which header you have to remove for this to stop downloading the PDF and start saying "Not found".

    Thanks in advance to anyone who can try this, and let us know if you have trouble following the steps. If this ends up being too complicated, there are other ways we can debug this, but they'd take a while longer.
  • OK, thanks to some very helpful debugging in another thread, I think I've figured out what's happening here, so no further debugging needed for the moment. We should have a fix soon.
  • This should now be fixed in Zotero Connector 5.0.52.
  • Hi I am having the same problem as many people above. Dstillman can you help me fix this?
  • @Meka3972: Make sure you have version 5.0.52 of the Zotero Connector. If you're still having trouble, it's likely a different issue, so start a new thread and provide a Debug ID from Zotero for a save attempt where the PDF isn't saved.
  • Hi I'm using Firefox (it's up to date according to About)
    Zotero 5.0.60 on Windows 10
    Zotero Connector is v.5.0.53

    Zotero is open in Windows.

    Logged into EBSCO through my school library. I click the PDF Full Text link and the PDF opens in the built-in Viewer. Zotero Connector displays the PDF icon. When I click it, it spins and then displays an X. When I click the X, is says "saving failed. Is Zotero running?" it is.

    Submitted Debug ID:

    I'm pretty sure this used to work for me.
Sign In or Register to comment.