Security certificate override with cert8.db on ZoteroPortable

edited November 12, 2018
Hi all,

I have v 5.0.52 in PortableApps.

Even though I am not versed in Certificates, I understand my company installed its own certificate.
E.g., in Chrome when I am at and I go to menu -> More tools -> Developer tools -> Security tab -> Overview I see
Certificate - valid and trusted
"The connection to this site is using a valid, trusted server certificate issued by _the name of my company_ WebGateway CA."

I find a few issues, I think all of them a consequence of the certificate issue:
1. In both Chrome and Firefox connectors I have the well documented issue of not retrieving the author names.
2. If I try to update Zotero I get "Update XML file malformed (200)".
3. I cannot sync

To deal with issue #1, I tried updating Zotero as a first step; possibly not a solution, and perhaps not even needed, see . At any rate, it would be useful to be able to update.
Then I got issue #2.

So I tried overriding the certificate as shown here .
I also checked

But the problem is my cert8.db under C:\Users\user1\AppData\Roaming\Zotero\Zotero\Profiles\_randomstring_.default\ is locked for editing/removing as I have my Zotero session open. And as soon as I exit Zotero, the whole directory C:\Users\user1\AppData\Roaming\Zotero disappears (I guess this only happens with the portable version).

What should I do to override the certificate?
  • edited November 12, 2018
    We don't have anything to do with the portable version, so you'd have to figure out where the profile files are coming from and overwrite cert8.db in the original location.
  • I installed the regular version, and now directory C:\Users\user1\AppData\Roaming\Zotero is permanent (it does not disappear when I exit Zotero).
    So I could override cert8.db, and now I solved issues 1 and 2. Still cannot sync... I have to do some more research and/or post another thread.
Sign In or Register to comment.