Problem editing Chicago author-date reference when placed in a footnote

I'm having some trouble *editing* (i.e. not adding) citations of the Chicago author-date kind when it is placed in a footnote. I can insert citations in footnotes without any issues, but if I try do edit it later, I get a message saying "You must place the cursor in a Zotero citation to edit it"...even though I emphatically have the cursor inside the citation.

Mind, this only happens when I have placed a citation within a footnote. I can work around it by deleting the whole citation and inserting itn again, but this can be a pain when citing several works. So, not a huge issue, but might be something worth looking into. I tried to search for other posts on this issue, but found nothing.

Should it be of interest, I have had the exact same problem when running Zotero standalone on Windows 7 and Windows 10, with Word 2010 and 2016 respectively.
  • Hmm, works for me on Windows 10 with up to date Word. You can replicate this consistently from the sound of it?
  • Well, the thing is it's not completely consistent -- which just makes the whole thing a lot harder to figure out. I'm struggling to pin down a single factor that makes this happen as well. By far the most common differences between my citations is whether I specify a page number, and/or whether I check "suppress author". I have gotten the error message with different permutation of this, but there are indeed quite a few citations that I am able to edit.

    I thought this might have been a computer/operating system/word version-specific thing, so I just worked around it. But now I get the exact same thing with a different computer, running a different Windows and Word version. I was actually very surprised that there were no other posts about this on the forum because it now seems highly unlikely that I am the only one that has experience this. That is, if I don't have some highly idiosyncratic ways of using Zotero that causes the problem...but that does seem unlikely as well. That being said, I have opened both the documents I experience issues with on my old computer as well, and don't really have a (longer) one that has been opened with the new one only. So, feasibly it was a weird bug that travels with the document even if you change most other things. That is the most reasonable explanation I can think of at the moment.
  • So I'm understanding this happens in one specific document -- you can't make it happen in a new one?
  • It happens in several documents -- it has been for several years. I did try to recreate it in a new document and was unsuccessful, though I have a strong feeling that this mainly happens with large documents (20+ pages), and as I mentioned it is in any case not entirely consistent -- even in the "affected" documents. I tried copying the whole text in an affected document into a new one, but this also did not resolve anything.

    The latter point in my previous comment was that all of the documents that have this issue have at least been processed (though not necessarily created) on the same old laptop. This may feasibly be corrupting part of the Zotero register (or whatever it's called). It's a kind of a strange problem as well, because even though Zotero gives me an error message that would indicate it cannot see/read the citation when I try to edit it, the same citation will still appear in the bibliography (seemingly a "left hand doesn't know what the right hand is doing" kind of dynamic).

    Anyway, seeing as I still cannot be certain that this issue is still being *created* in a new setup, I should perhaps let this lie until I see the issue in a document that has only been processed on my new computer.

    Thanks for your help/interest!
  • Update: It has now definitely occurred in a document that has only been on my newest setup. I tried to delete the citation that got the error and put a duplicate citation in. As usual, this did not help. I then tried putting a duplicate citation after the one I was unable to edit. Specifically, the end of the footnote looked like so:

    " well as other castes (see Toffin 2007, 131–34). (see Toffin 2007, 131–34)."

    I was then able to edit the latter reference, but not the former. I then tried deleting the former (uneditable) citation and put the latter one in its place. This then became uneditable as well. I'm not precisely sure what this proves, if anything, other than this being a strange problem...
Sign In or Register to comment.