Word is missing as a choice as Word Processor

I only have LibreOffice as a choice
macOS high sierra
Word 2016
  • In Tools → Add-ons → Extensions, do you see the Word integration plugin listed, and is it enabled?

    If it's disabled, enable it. If it doesn't show up, reinstall Zotero. (Your data won't be affected.)
  • Here’s the thing now. Every time I install word, zotero corrupts Word. If I uninstall zotero, Word works. I was on the phone with Microsoft for 3 hours. They couldn’t resolve the issue.
  • I'm not sure what you mean by "corrupts Word". The only thing Zotero does is install a toolbar into Word that doesn't run at all until you interact with it.
  • No one understands why it happens. If I have Zotero installed, Word will not open. "Word" is the only item in the tool bar. I have to force quit. When I force quit, I get a message that says "There was a problem and Microsoft Word was closed."
  • The only way to have a fully functioning Word is to uninstall Zotero.
  • "Word" is the only item in the tool bar.
    What toolbar are you referring to?

    How are you uninstalling Zotero?

    What exact version of Word?

    All Zotero does is install a Word template (a .dotm file) in the Word startup folder. That could theoretically cause a problem in Word (though that's very unlikely, and not something others have reported), but if by uninstalling Zotero you simply mean that you're deleting it from Applications, that wouldn't have any effect on Word, since that doesn't remove the .dotm file.

    If you're uninstalling using some third-party program that also deletes the Zotero.dotm file from the Word startup folder, that would point to some sort of conflict with the .dotm file that we could debug further. But simply removing Zotero from Applications wouldn't have any effect.
  • I’m referring to the Word toolbar.
    Yes, I’m uninstalling Z by just putting it in the trash.
    I have Word Version 16.16. I downloaded the Office apps from my school’s website.

    The problems all began when I tried to fix an error I was getting. The error said Word could not connect to Z or vice versa. The zotero.dotm was not in the Word Startup folder. I copied it and pasted it into the Word startup. Word would not open after. The other thing that happened is Word disappeared as a choice in the Word Processor option under Cite in Zotero.

    I wish I could include screen shots to help explain.
  • edited August 28, 2018
    Yes, I’m uninstalling Z by just putting it in the trash.
    But again, though, the presence of Zotero in the Applications folder has absolutely no effect on Word. The only thing that has the potential to affect Word (though no one else has reported it) is the presence of the Zotero.dotm file in the Word Startup folder.

    If the presence of Zotero.dotm in the Word Startup folder is causing Word not to start up, that's a problem with your Word installation, since it's just a standard Word template and obviously works for others.
    I wish I could include screen shots to help explain.
    You can upload screenshots to Dropbox, imgur, or similar and provide a link here.
  • Ugh. I am completely in over my head. How do I find out if Zotero.dotm is in my Word Startup folder? That is where I am really lost. I followed the instructions on the troubleshooting page, but what I find does not match the instructions.
  • https://www.dropbox.com/s/atqvhd3fcsins0g/Screen Shot 2018-08-28 at 1.00.17 AM.png?dl=0

    I don't see "Personal Settings." "Click on “File Locations” under “Personal Settings” and click on “Startup” at the bottom of the list. This may list your Startup folder location.
  • "Personal Settings" is just the header of a section in the preferences. Anyway, it looks like you found File Locations.

    So you have a Startup folder listed, but it appears to be set to an odd, incorrect location.

    You can open that folder in Finder using the instructions on the linked page, using ~/Library/Group Containers/UBF8T346G9.Office/User Content/Document Elements instead of the …/Startup/Word folder.

    If there's a Zotero.dotm in there, I would delete it and then reset the Startup directory in the File Locations dialog, which will hopefully clear that setting so that it uses the default of …/Startup/Word (as mentioned on the linked page). After that, close Word and try reinstalling the Word plugin normally from the Cite pane of the Zotero preferences, or follow the manual instructions to place Zotero.dotm into the Startup/Word folder.
  • Oy. I feel like an idiot. I see the Personal Settings.
  • I’m not sure what that’s meant to show. If you’re still having trouble, you’ll need to say what the problem is.
  • Ok. I think the startup is now in the correct location: https://www.dropbox.com/s/12ydoo276uwi76f/Screen Shot 2018-08-28 at 1.47.14 AM.png?dl=0

    I double clicked startup and it took me here:
    https://www.dropbox.com/s/xer4x46zyws7ieb/Screen Shot 2018-08-28 at 1.51.10 AM.png?dl=0

    Where do I paste the copy of the zotero.dotm?
  • More importantly how do I paste the copy (which I made by right clicking and choosing copy)?
  • I looked over this thread.

    "In Tools → Add-ons → Extensions, do you see the Word integration plugin listed, and is it enabled?"

    It is not listed.
  • It is best if you just click "Reset" for your Word startup location, which will ensure it's the default one.

    You need to make sure Word integration is present in Zotero Tools -> Add-ons -> Extensions. If it is not present at all, you should download Zotero and reinstall with the downloaded version, then see if the Add-on appears. If it does, you should go into Zotero Preferences -> Cite -> Word Processor and reinstall the Word plugin, which will make Zotero tab appear in Word. If Word begins crashing after you do this, it indicates that something is wrong with your Word installation.

    If you get stuck at any of these steps, please post with details what have you done so far and where you got stuck.
  • I have once again downloaded and reinstalled Zotero. It still is not present. I don’t understand why it will not appear. Is something blocking zotero from downloading correctly?

    I still do not understand how to copy zotero.dotm. Nor do I understand where the copy is to be place or how to place it there. When I click on the startup folder, there isn’t an option to paste it. I have used keyboard short cuts for copying and pasting. I have tried right clicking to copy it to the startup folder. Nothing happens.
  • Don't worry about copying zotero.dotm to the Word startup folder for now. Could you submit a Report ID?
  • 101580252

    1. Start Zotero.
    2. Click on Zotero.
    3. Click on Preferences.
    4. Click on Word Processors.

    Microsoft Word 2016 is not available. Only LibreOffice is listed.

  • Zotero Word for Mac Integration (3.5.14, extension, disabled)
    This shows that the Mac Word plugin is disabled. Above you said that you didn't see it listed in Tools → Add-ons → Extensions in Zotero. Can you provide a screenshot of that?
  • OK, so it is listed, and it looks like you downloaded and installed the old plugin for Zotero for Firefox. Current versions of Zotero come with the word processor plugins, so you don't need to (and shouldn't) install anything.

    Click Remove, and then restart Zotero.
  • IT'S WORKING!!!!!!!!!!!!!

    Thank you!!!
Sign In or Register to comment.