Bug: touchscreen double-tap to open pdf sometimes drags the pdf entry away

Hi everyone!
I'm trying to switch to Zotero, after finding out Mendeley encrypts my database.
I was able to move my database to Zotero more-or-less successfully. Now just playing with it, I found a very annoying bug, that corrupts my database:

When I double-tap on pdf file entry to view the pdf, sometimes it doesn't open the file. Instead, it appears to trigger a drag-drop, and the pdf ends up disconnected from the reference.

Even more annoying, the undo button is grayed out after that. So undoing the damage is really hard.

Screencast gif:


Zotero 5.0.54 on Windows 10 rev. 1083

Doesn't happen if I use pen instead of touchscreen.

Any help appreciated. Is it possible to disable drag-drop in this tree view to stop the damage, until the bug is fixed?
  • I'm not sure that's a Zotero bug. That seems more like a sensitivity setting for whatever software is controlling the touchscreen, and something that might be happening more generally but just in places where a short drag doesn't have noticeable effects.

    It's vaguely possible that an updated version of the Mozilla platform Zotero is based on — currently a version of Firefox 52 ESR, but soon to be Firefox 60 ESR — would help here, but I'd play with your touchscreen settings to start.
  • You can try testing this on https://dunnbypaul.net/js_mouse/ in your browser and see if elex,y changes when you try to double-tap on one of the green boxes. (If it doesn't happen, you could also check Firefox 52 ESR to see if it happened with that, which would tell us if the Firefox 60 ESR upgrade will help.)
  • @dstillman
    I tried the javascript example. elex,y doesn't change as I double-tap draggable objects in chrome and edge. Moreover, none of the "draggable" stuff can be dragged with touch input - only with touchpad and pen can I drag anything. Touchscreen scrolls.

    I'll try firefox later.

    The software controlling the touchscreen appears to be windows itself. There are not many settings offered. One of them is double-tap distance tolerance. I tried decreasing it to minimum, but it doesn't seem to make any difference.
  • edited August 1, 2018
    Tested in Firefox 52. Thingies do move upon double-tap. A little bit, and only sometimes.

    EDIT: and I can drag the thingies with touchscreen.
  • Tested in Firefox 61. Nothing ever moves, just like with edge and chrome.
  • Can anyone point me to a place in the source code where drag-drops are handled? I tried to find it myself, but so far without luck. My javascript coding capacity is pretty poor, but it shouldn't be too big of a deal to break some drag-drop, for my purposes ;)
  • edited August 1, 2018
    Tested in Firefox 52. Thingies do move upon double-tap. A little bit, and only sometimes.
    OK, so that’s the same behavior, and if it’s not happening in a newer Firefox this will likely go away with the upgrade to a Firefox 60 base, which will happen by September. (There will be a Zotero beta version based on Firefox 60 soon.)
  • Awesome, thanks, I'll be checking periodically.
  • Hi, I know this is a two year old thread, but I'm experiencing this on my (new to me) Surface Pro 4. Every time I try to click on a PDF directly to open it, it moves the PDF outside the parent item and into the collection. No "undo" is available. I also can't double click on the parent item to open the PDF. However, everything works fine with a mouse.

    Can't move any of the boxes in the Javascript test link provided when using Chrome 81.0.4044.138 or Firefox 76.0.1. In Edge 44.18362.449.0 they try to move (as in, I can see them being selected), but then it either scrolls or tries to go back or forward (depending on which way I try to drag).

    Zotero 5.0.87 and Windows 10 Pro 1909. Neither seem to be able to be updated.

    I submitted a debug output, ID D1259468373.

Sign In or Register to comment.