Zotero & Scrivener HELP!!

edited July 19, 2018
Hi, I followed the instruction here to integrate Zotero to Scrivener on Mac

I was required to run

pandoc –bibliography \
~/.pandoc/My_Library.bib \
–csl ~/.pandoc/ leiden-journal-of-international-law.csl \
-f markdown -t docx \
-o ~/Documents/PhD/export/pandoc_text.docx ~

Then I got this..

Last login: Thu Jul 19 23:57:04 on ttys000
Beibeis-MacBook-Pro:~ beibeizhang$ pandoc –bibliography \
> ~/.pandoc/My_Library.bib \
> –csl ~/.pandoc/ leiden-journal-of-international-law.csl \
> -f markdown -t docx \
> -o ~/Documents/PhD/export/pandoc_text.docx ~
pandoc: –bibliography: openBinaryFile: does not exist (No such file or directory)
Beibeis-MacBook-Pro:~ beibeizhang$ /Documents/PhD/export/pandoc_test
-bash: /Documents/PhD/export/pandoc_test: No such file or directory
Beibeis-MacBook-Pro:~ beibeizhang$

What should I do? Does anyone have these experience?
Many thanks!!!

What is the most updated way to integrate Zotero to scrivener?
  • hard to troubleshoot what is really a pandoc issue, but the error messages look like Terminal is reading this as multiple lines. So try running instead.

    pandoc –bibliography ~/.pandoc/My_Library.bib –csl ~/.pandoc/leiden-journal-of-international-law.csl -f markdown -t docx -o ~/Documents/PhD/export/pandoc_text.docx ~/Documents/PhD/export/pandoc_test
  • Thanks but still does not work
  • same error message? and do you have pandoc installed and working with simple commands?
  • is it possible to do it through Marked2?
  • edited July 20, 2018
    BTW if you're using pandoc for anything else than producing latex documents (or PDF derived from latex documents) I'd strongly recommend using CSL JSON (or Better CSL YAML/JSON if you want the BBT citekeys) instead of biblatex.

    If you're producing tex, pandoc will just call the tex engine with the bib file you hand it, but for all other output formats, pandoc translates to CSL JSON internally before anything else, as the pandoc citation processor can only really use CSL. Pandoc's biblatex parser also does not deal with title casing according to spec, and you sidestep that too if you just use CSL.

    So right now, your process does

    Zotero |BBT| BibLaTeX |Pandoc| CSL

    where you could just do

    Zotero |BBT/Zotero| CSL

    It'd be a lot faster (all Zotero CSL exporters, even BBTs CSL exporters, are faster than BBT BibLaTeX), and it'd be better, too, because the back-and-forth translation to/from biblatex is not entirely lossless.
  • Thanks a lot!!I study law..that is a little bit too hard for me...but I will do some research about it.
  • edited July 21, 2018
    Just export to "Better CSL JSON" instead of "Better BibLaTeX", and then call

    pandoc --bibliography ~/.pandoc/My_Library.json --csl ~/.pandoc/leiden-journal-of-international-law.csl -f markdown -t docx -o ~/Documents/PhD/export/pandoc_text.docx ~/Documents/PhD/export/pandoc_test
    At least one of the errors you are seeing is probably because you used – (em-dash) rather than -- (double-dash) for the options in the command.

    I'd recommend storing your library with the document, so ~/Documents/PhD/export/My_Library.json rather than ~/.pandoc/My_Library.json .
  • edited July 20, 2018
    (I can't help you with Marked2 because I don't currently have a Mac -- still saving up for the macbook)
Sign In or Register to comment.