Finding more recent Zotero library

Recently I updated to Windows 10, and then to Zotero 5.0. When I went to open Zotero, the program couldn't find my library in the Zotero folder that it automatically created. I was able to locate a local folder on my desktop that had a library in it with a number of entries ("last modified" date from 2014) that I probably copied to the desktop when I bought the laptop. However, it did not include library entries from other projects that I had worked on since then. I have tried to find the data from these more recent projects using the file paths listed on your support documentation, but am struggling to find anything. Any help anyone could provide would be helpful. Thank you.
  • edited July 8, 2018
    Try to search your computer for “zotero.sqlite”. Are you using Zotero sync?
  • I did this a few minutes ago, and was able to find another folder on a backup hard drive that has at least some additional dictionary entries in it. This appears to be the most recent backup of the Zotero program files (I have been fairly conscientious to back up files manually, but, unfortunately, I only backed up documents and not program files). Also, I didn't use Zotero sync until I downloaded version 5.0, and it did this automatically for me when I logged in to the website.

    Alternatively, is there a way to populate the Zotero library "backwards" from the bibliographic data in the citations of the various papers I have written? I realize that the dictionary entries wouldn't contain information in all of the possible fields that they might have had originally, but would at least have basics such as author, title, publisher, and pagination.
  • I would recommend starting with the most recent database you can find (and placing it in the default location ~/Zotero and adding this to your backup system).

    Then you, can extract items from Word documents you’ve created with Zotero using:

    This will extract all the fields that had been in your library at the time. You will probably need to merge duplicate items after extracting and re-importing them.
  • Sounds good. And when I place the database in the default location, can I just copy and paste all of the folders/files into it and overwrite any duplicates that already exist there? Currently the folder that contains the most recent database only has 4 folders (locate, storage, styles, and translators) and the zotero.sqlite files and its backups in it.
  • Actually, I just took a look at the destination folder, and it doesn't contain any of those folders or files, so I should be okay just to transfer it without worrying about fouling anything up.
  • The destination folder did contain alternative versions of the folders/files, but it transferred fine. And the reference extractor worked well, although Zotero didn't like the CSL JSON format, for some reason (I ended up using BibTeX).
  • although Zotero didn't like the CSL JSON format, for some reason
    What kind of error did you get? The reference extractor produces BibTeX from the extracted CSL JSON, so the extraction itself must have worked.
  • @kmtaylor, we just got another report of somebody who had trouble importing the CSL-JSON file into Zotero ( If you'd be willing to (privately) share the Word document in question, or a smaller section that still gives the same CSL-JSON error in Zotero, I'd be happy to take a look to see if there is a bug I can fix.
  • I got the same message as the other Zotero user was experiencing. I would be glad to share the Word document with you--especially if there is a chance that it will transfer the data better. It appears that the BibTeX version didn't put any of the dates into the Zotero library entries.
  • @kmtaylor, I left you a Zotero message with my email address (see the "Inbox" link at the top of this webpage).
  • @kmtaylor, thanks for sending the Word document. It turned out that there was a general bug in the CSL JSON output since May 20th, which should be fixed now. Let me know how it goes.
  • @kmtaylor, I reported your problem with the BibTeX dates upstream, and this issue should now also be fixed.
Sign In or Register to comment.