Restoring a deleted library

edited June 14, 2018
While trying to sort out some problems with my computer, we had to wipe my user profile, so my setup on the computer. My computer is synced to our department network, so all my documents were saved there, and it was only any customised settings I had that should have been affected.

What we didn't realise, was that my Zotero library was saved on my profile, and not on the network like everything else. The standalone program is still there, but none of its contents.

This means that it wasn't stored on my hard drive, or on our network, and all my Zotero records have now been deleted. I expect it's hopeless, but in case anyone has ideas on how we could salvage the data, I'm posting.

Other issues that have made this hard to sort out:
1.) My computer seems to have been set not to keep system backups, so we can't roll it back.
2.) I hadn't synced it to my online Zotero account (I will from now on!).
3.) We've tried recovery software and it didn't work.

  • What version of Zotero were you using before you wiped the profile?

    If you search for “zotero.sqlite” does it return any results other than the new empty database?
  • "we had to wipe my user profile"

    Probability of data recovery depends on exactly how your user profile was wiped and what value the data has.

    I would immediately stop using your local PC, in case your profile (which might still be buried in your PC drive) is overwritten. Then get IT department to apply data recovery to your hard drive.

    Further advice on tools to use can be offered. Windows or Linux?
  • Thank you. I really appreciate this support - I've been using Zotero for about 2.5 years and losing everything is going to be genuinely impossible to sort out completely.

    I'm using version, on a Windows machine.

    I searched for zotero.sqlite, and there do appear to be two entries. One is 88.6KB, the other 1.20MB, both from around the time when we changed everything. Does this suggest that the old library is still buried somewhere? If this is the case, how would I go about recovering it?

    I was sure that I'd agreed to 'store references in document' so I tried the reference extraction on various documents with Zotero links in them, but no references were found, so it seems like that didn't work either.

    IT have already tried data recovery on the computer, without success. It seems that the two options they had (BadCopyPro and SpinRite 6.0) don't work on my computer. System backup has been disabled, so there are no restore points. I've got no idea why my computer is so awkward, but it has been problematic ever since I've had it.

    If it isn't recoverable, I should still be able to import references from bibliographies I've generated, shouldn't I? It looks like it might require quite a lot of reformatting, but that will still be faster than trying to reconstruct it by hand.
  • First thing I would do is to copy the zotero.sqlite files you have found by your searching around and place them into a safe location. That find does looks encouraging.

    Perhaps you could try these files on a different PC as zotero databases before progressing into deeper recovery as explained below?

    But if your profile has been erased you will not find files by simple searching. Your IT department will need to apply forensic data recovery tools to recover the erased files. There is a fair chance if you have stopped using your PC that recently erased files (simply through Trash) can be recovered. In fact have you looked in Trash can for profile data?

    If “del” command has been used to delete then the recovery is harder.

    It is a surprise that SpinRite does not work since it has a good reputation.

    Ask IT department if they can try running testdisk.

    There is also EaseUS Data Recovery

    Remember that recovered files need to be saved into some location and it is counter productive saving recovered files into the same drive you are recovering (you might overwrite the very files you are trying to recover). I would have a USB flash drive on standby where you can place any recovered files.

    Another point is that this process can take many hours to complete. Overnight runs are not unusual.
  • I searched for zotero.sqlite, and there do appear to be two entries. One is 88.6KB, the other 1.20MB
    @ClassicsCressida: Those aren't super promising, unfortunately. 88.6KB is nothing — I'd guess that's not zotero.sqlite but zotero.sqlite-[some other extension]? And 1.2 MB is fairly close to an empty database, which is what you'd end up with if you opened Zotero after wiping the profile. What's the location of that file? Do you see a 'storage' folder in the same directory, and if so does it contain subfolders?
    If it isn't recoverable, I should still be able to import references from bibliographies I've generated, shouldn't I?
    See Importing Formatted Bibliographies for some options.
Sign In or Register to comment.