Safari connector does not show in extension list

I've downloaded the Safari Connector and double clicked it, then I'm transferred to the safari-preference-extension list, there is a pop-in window asking me whether I trust this extension and I clicked trust, but zotero still does not show in the extension list. Can anyone help with that?
  • It's a bug, and I also spent a considerable amount of time figuring it out. But here's the solution:

    Go to System Preferences > Keyboard > Shortcuts > Keyboard
    At the bottom of that dialog box, change the Full Keyboard Access option from "Text boxes and lists only" to "All controls".
    Dismiss the System Preferences window.
    Return to installing the extension. Double-click the Safari Extension file, and when the "Are you sure you want to install..." dialog box appears, do not click the Trust button. Instead, use the Tab key to select the Trust button and then press the space bar to confirm.
    Feel free to change the Full Keyboard Access setting back to "Text boxes and lists only" so the system behaves as before.
  • Thank you vladimirbizik, it works!
  • As a former developer, I can appreciate the effort it took to find that one! Stumped me until I found this. You might want to put a reference to it on the download page for Safari users. Thanks!
  • We'll look into adding a note, but you should also report it to Apple:

    We've never seen it ourselves, but it's been affecting Safari extensions for years.
Sign In or Register to comment.