This.registry.citationreg.citationById[c[0]] is undefined


I have been using zotero for more than one year and I have started to have problems from yesterday when I installed Windows 7, Word 2010 (in spanish) and the beta version of zotero. The style I'm using is American Soc. Asociation; I've tried to change style, but I couldn't. I have tried everything what is suggested above (even reseting translators and styles... and I have tried other ways too such as removing from the library and text which I thought was a conflicting item). I have received diverse error report with the same problem..

This.registry.citationreg.citationById[c[0]] is undefined

'Zotero is experiencing and error updating your document.
Citation is undefined'

'a field note is corrupted'...

Also some references have changed (e.g. 'Bourdie 1991' which was bellow in the text appear when should be 'Pink 2006' for example... That's scaring!).

What should I do. Help!
  • Hi,

    I have the same problem as ceramire. I updated Zotero to 2.1.2 (no updates for the Winword and OpenOffice plugins available) and if I try to insert anything in Word 2003, I get this annoying message and Zotero doesn't insert anything.

    Help! Help!
  • This has been reported before, and I've been waiting to see whether changes in 2.1.2 would affect the behavior. Sadly not, but no fears, we'll nail it. Some debugging code has been added to the processor to help track down the cause. Please submit a Debug ID report, and post it to the forums.
  • Hi fbennett,

    I just put it here. Is that how you are supposed to do it?
  • edited March 31, 2011
    Yep. Simon or Dan will pick it up later, and may have some more questions for you.

    (Oops, sorry, I linked the wrong page. What Dan said.)
  • Simon may be able to tell something from the Report ID, but rickus, fbennett asked for a Debug ID, not a Report ID.
  • 42577012 report id.

    I keep getting a registry is undefined error when I try to use APA format. ASA works but I have to use APA help
  • What is your version of Zotero?
  • 2.1.6
    Error in getField: term "PAGE" does not exist.

    An item in this document is missing from your Zotero library.

    [JavaScript Error: "this.registry.citationreg.citationById[c[0]] is undefined" {file: "chrome://zotero/content/xpcom/citeproc.js" line: 2738}]
  • Uppercase PAGE is certainly a surprise. I can prevent that from causing a problem, so let's start there.

    I'll be tied up with other things for the next few hours, but I'll put up a processor release that addresses at least part of the problem here later in the day.
  • edited April 30, 2011
    I think I have a handle on why we've been seeing these intermittent low-level errors. We'll have to wait and see, but I'm pretty sure they can be eliminated for Zotero 2.1.7.

    The (very slightly) technical story is that the citation formatter runs twice each time a citation is inserted -- once for preview, and once to render the citation for insertion. It think what's been happening is that if the processor crashes during preview (in this case when it sees a label term of "PAGE" instead of "page"), its internal registry (one entry for each item) is left in a corrupted state. Some of the data is missing, and that causes the "something-something is undefined" error when Zotero attempts to run the processor a second time for the document insertion.

    The solution (apart from a band-aid to protect against weird things like the "PAGE" term) will be to assure that a processor crash during preview does not leave the registry in an incomplete state. I'll get that fix in place soon, for the next Zotero release.
  • @heatheremory,

    If you check your messages on, I can send you a private version of the Zotero 2.1.6 client that uses a new version of the CSL processor that may get you going immediately with APA.
  • Aha. Might also explain why I ran into it and why my workaround worked.
  • A further question though - if we weren't as lucky as Mark to have a pre-corrupted version of our document saved, then how do we repair the document? I can no longer insert new citations, or edit some of the old ones due to this error. I've upgraded to the latest version of Zotero today (after the problems started with an earlier version) but it hasn't help.

  • Hi, Thanks for the quick reply - I tried copying and pasting into a new document and that seems to have fixed it. Thanks!
  • I seem to have a new version (3!), and it tells me that my paper cannot be fixed or upgraded or edited because
    this.registry.citationreg.citationById[c[0]] is undefined

    I can't get anywhere.

    I didn't upgrade. I don't have time for this, and auto upgrades should not make me miss my conference submission deadlines. Help!
  • akinto2: Follow the Debugging Broken Documents steps linked above. We believe most or all of the causes of this are fixed for 3.0.2, which will be out shortly.
  • Just a heads up in case anyone else has gotten this error recently: these days updating to zotero 5.0.43 fixed it without any need to debug the document.

    So just close the document, then close and restart zotero and either let it finish updating (if it comes up), or go to top menu-->help-->check for updates. Once zotero is up to date, then open the word doc and try again.

    My zotero on mac had stalled in the middle of an automatic update, and word was throwing up this error. I didn't know it was updating until I went manually and checked the update window.

    Just waiting for the update to finish didn't work in my case, even though the update window said it was finishing. But I didn't need to do anything to the document itself.

    Before that I did have the most recent build installed, MacOS Sierra, Word up to date, so it happened even on a relatively recent version of Zotero.

  • I just experienced this error and restarting Word and Zotero seemed to resolve it.
Sign In or Register to comment.