Error with pdf

I'm completely new to Zotero and also completely lost as I'm french and my English is approximative.
I'm with google chrome, I've just install Zotero ( the most recent version I guess) and I'm with windows.
I can save pages but no pdf. Indeed, it is always written :
"an error occurred while saving this item blablabla..."
I tried to solved it by looking the help service but there are so many things and my English is not very good.

Thanks for your help

  • Can you provide a Debug ID from Zotero (not the Zotero Connector) for a PDF save attempt that fails?

    Feel free to write in French.
  • If I write in French only french people will be able to understand me... Google traduction is sometimes disappointing.
    I finally found what you were asking for : D1396043988
  • Most of the people who will help you here can read French.
    Win error 5 during operation move on file C:\Users\[…]\Zotero\storage\tmp-mSRkzD (Accès refusé.
    There've been a few reports of this, and the most likely cause is security software on the system interfering with Zotero's ability to move newly created files. So if you're running any security software, try temporarily disabling it.

    Does this happen for any PDF, or only certain ones?
  • Ok, I'll try again while disabling some software.
    Does avast would refrain me from using Zotero?
    It happens with every pdf.
  • Report ID: 1157826349 Zotero connector beta
    Firefox 59.0.2, Windows 10, Zotero 5.0.43-beta3+4f9847da0 (but happened with earlier beta versions too): I cannot save pdfs via the icon anymore, because of an error occurred while saving this item. I tried also creating a new profile in FF 59.0.2 changed nothing only installing zotero connector beta, but the bug did not go away.

    The new pdf recognizer is a great new tool! It recognized ~1/3 more of my pdfs than the old google pdf tool.
  • edited April 3, 2018
    @dani-: Could we see a Debug ID from Zotero for a save that fails?
  • Yes, of course: D1774355249
  • I did some more tests e.g. on Windows 7, everything worked nicely. There must be something incompatible on my notebook, disabling and pdfs are saved again, no error message anymore: zotero 5.0.44-beta2+89d7dad12 and zotero connector 5.0.36beta4.
  • edited April 4, 2018
    Security software is the likely problem here, but is that reproducible? If you re-enable it, does the problem return?
  • Sorry for not making this clear, of course I could reproduce the problem by re-enable malwarebytes.
  • OK, thanks for confirming. @Tchoupy, were you also able to fix this by disabling security software? It's fine to run security software alongside Zotero, but depending on what the security software does, you may need to disable certain options or exclude the Zotero data directory from processing. In this case, Zotero saves a file to disk and then moves it to its final location when it's done downloading. But if something reads and locks the file before the move happens, it could block the move and cause the save to fail.
  • Just a heads up for the Malware Bytes problem. I fixed the issue on my system by completely uninstalling Malware Bytes. Use the Malware Bytes Cleaner to perform the uninstall. I then went into the registry ( I use a registry editing tool called jv16 Power tools) and deleted every key associated with the MalwareBytes. There were quite a few left over. Reinstalled Malware Bytes and tested. Works fine at this point in time.
Sign In or Register to comment.