Copy and Pasting Very Slow

I noticed about a month ago that copying and pasting in Zotero has gotten very slow for me. Every time I copy OR paste something anywhere on Zotero is stops momentarily, I see the little spinning wheel, and then it finally copies or pastes after about five seconds. It makes quick editing or duplicating information difficult. I don't have this problem in any other application, so it's not a system-wide problem.
  • Could you produce a Debug ID from Zotero?

    1. In the Help menu, go to Debug Output Logging and select Enable.
    2. Perform the operation that is usually slow
    3. Before doing anything else, return to Help → Debug Output Logging and click Submit Output, which will disable logging and submit the output to A window should pop up containing a Debug ID. Click “Copy to Clipboard” and paste the Debug ID into this forum thread.
  • Done! Debug ID is D260845279
  • edited March 16, 2018
    When doing this, are you in a collection or saved search, or do you have a quick search entered or tag selected?

    The debug output you submitted was for copying? There wasn't actually any activity in the output, and I'm not really sure what it means for copying to be slow — there was no indication that it was searching or anything like that (which would be indicated by the spinner). What exactly makes you say that it was slow in this case?
  • The debug output I sent above is from trying to copy and paste in a note attached to a document. It was in a normal collection, not a saved search and I did not have a quick search entered or tag selected. I still saw the spinner and it took about 5 seconds for it to complete the copy and another 5 seconds to complete the paste. I've noticed it also does it when I try to undo with command Z and in fact also when I try to select all with command A. Perhaps it's an issue with command actions? I just sent another debug output where I copied and pasted info from one record to another (no search or tag selected) and then undid the action using command Z. These actions took about 5 seconds each and I saw the spinning wheel with each one. The debug ID for that output is D1066695842.
  • edited March 16, 2018
    I'm confused here. Neither of these reports show any changes being saved to your database. The latter one just shows the Archive Location field being opened and closed, but without the item actually changing. So that doesn't seem to match up with your description of what you're doing, unless you mean that you're undoing the change before closing the field.

    I'm now realizing, though, that by "spinning wheel" you perhaps mean the macOS beachball, not the spinner to the left of the search bar in Zotero. That sounds like a more general OS-level problem than a Zotero one (which makes sense, because pressing Cmd-C in Zotero doesn't trigger any activity in Zotero). Have you tried simply restarting your computer? If so, try disabling any third-party programs you're running. I can't recall anyone else reporting anything like this, so this is almost certainly something specific to your computer.
  • If you watch Activity Monitor while this happens, sorted by descending CPU usage, does it show Zotero at 100% CPU when this happens, or something else?
  • Yes, sorry, should have been more clear -- I do mean the beachball. When I watch Activity Monitor, Zotero spikes to about 70% when I copy or select all and 50% when I paste. Zotero is the only application that seems to have this trouble, but perhaps it could still be an OS issues?
  • Yes — strange problems like these that only one person reports tend to be conflicts with other software or other problems on the computer, and unfortunately there's not much we can do. You can try reinstalling Zotero (though that's unlikely to help), disabling third-party software, or testing in a new user account.
  • Hi, here are the things I tried:
    * disabling Addons: no change
    * uninstalling via Appcleaner and retry using a new just downloaded: no change
    * uninstall, renaming my data folder, restart Macbook, and start a fresh new Zotero: no change.
    I tried to record the screen, but the tools I found for this dont record the spinning beach-ball....
  • edited March 25, 2018
    Here is the Debug of the last one: D1933448092
    I also recorded that with Quicktime, but it doesnt show the spinning beach ball. It only shows a normal cursor.
    By the way there is nothing happening in the Debug Output Window when the waiting time occurs.
    The waiting time seems to start immediately when pressing keys like CMD+A, CMD+C, CMD+V etc...
    Mutiple keypresses are repeated, but take time. So if I press CMD+V multiple times, then switch to another App and copy something into the clipboard, that content gets pasted eventually when those multiple keypresses are 'realized'.

    I have also the feeling that in Firefox the same problem exists, but the slowdown is much less - maybe a half second or a bit less. But it is still noticeably slower than doing CMD+A and CMD+C etc. in a 'more native' App like BBEdit.

    Is there a non-public way to send the screen recording if needed?

  • You should try in a new OS account.
  • Aha, now, in a new user account it works really snappy. Great!
    That is strange! In the new account, I then started all kinds of programs that I have also running on my native account, but I wasn't able to reproduce the problem.
    So this means I must somehow have done something in my user profile that is the reason for this. Very strange, since I made a clean install (with format HDD etc) and did not copy my entire old user account folder to the new but only some folders, and only some preference files.
    Now I am a bit undecided - should I hunt down the problem, or simply start over with a fresh new user account....
  • So it's not just me! Using Zotero in a separate OS account is not really a workable solution for me (all my writing files are of course in my current OS account), so if you figure out what the issue is with your account, please share and maybe it's the same issue with mine.
  • edited March 26, 2018
    Now I tried a bunch of things, but nothing seemed to work.
    Then I did this (short form: boot into safe mode, then boot again):
    - restart your mac, immediately hold the shift key until the logo appears on screen
    - wait until you can enter your password, but then press restart
    - again immediately hold the shift key until the logo appears on screen
    - wait until you can enter your password and login then. There should be a red 'Safe Mode' text displayed at some time on the top right, by the way. But you will notice by the slow graphics that the system is starting in safe mode then. If it's not, repeat.
    - Since I was curious I started Zotero after this - but this is not necessary I would say.
    - then Reboot again without pressing any modifier keys.
    Now it works as snappy as is should, at least on my machine... Let's hope it will stay like this...
    It seems macOS got again a step more like Windows, though...

  • The Safe Mode fix worked for me so far! Fingers crossed it sticks. Thanks!
  • Weird. OK, let us know if it comes back.
Sign In or Register to comment.