After copy by dragging, the cursor disappears.

edited March 6, 2018
When I make a new note and copy some texts on browser by dragging, the cursor disappears.

- Make a new note.
- Select some texts on browser.
- Dragging the texts on the note --> texts are copied
- However, the cursor disappears.

P.S. When I copy and paste the same texts by Ctrl+C and Ctrl+V, it works normally.

Please have a look. Thanks.

Zotero 5.0.36-beta.6+079cb258f + Windows 7
  • What do you mean by "the cursor disappears"?
  • I the note I can't find a blinking cursor which looks like |.

  • But can you just click in the note again?
  • Sure, I tried. However, clinking again the note doesn't make the cursor appear.
    I have to re-open the note, then I can see it.
  • No. In TiyMCE demo copying by dragging works normally.
  • Is this happening dragging from anywhere, or only from specific sites? Does it happen every time? I assume you've tried restarted Zotero?

    Can you provide a Report ID after it occurs?

    You've seen a lot of unusual behavior in notes that no one else has reported — I'd guess from something about your input setup — so I'd be surprised if we were able to fix this unless you can provide exact steps that we're able to reproduce.
  • report ID: D1609290397

    - I made a new standalone note.
    - I dragged your texts above into the note.
    - It was copied without the cursor..

  • That works fine for me, I'm afraid.

    You can try in a new new profile (pointed at the same data directory is fine) to see if there's a setting in your current profile that's affecting this.
  • For your understanding I made animated gif file.
  • I changed the data directory (from custom folder to default folder)
    However, the same error...

  • No, a new profile, not a new data directory. Follow the link I provided.
  • I tried.

    - I made a new profile.
    - Started Zotero with new profile.
    - Tested
    --> the same error...
  • Have you tried from different browsers?

    You can also try in a separate note window to see if that's any different.
  • edited March 7, 2018
    Yes. I have tried from different browsers.

    - FireFox --> the same error
    - Vivaldi --> the same error
    - Explorer --> the same error
    - Chrome --> the same error
    - Whale (developed by Naver) --> the same error
    - separate note window --> the same error

    I tried on different computers(home and office) --> the same error

    I tried from Hangul NEO (Korean Word Processor) --> the same error

  • When I copy and paste by Ctrl+C,V, as soon as I paste there appears the cursor(|) on the note.

    However, copying by dragging, I have to click the title of the note to see cursor(|) on the note.
    As I remember, until now there has not been such an error.

  • Have you tested whether this occurs with The beta actually includes a newer version of TinyMCE, among other things.
  • edited March 7, 2018
    I haven't noticed it.
    Could I try now?
    If you let me know how to download the version, I will try.
  • OK. I downloaded

    I tried to copy by dragging. It worked perfectly.
    As soon as I copy the text by dragging it is copied normally without error.
  • Actually, never mind my previous message — I was just able to reproduce this.
  • OK, try the latest beta.
  • Yes. You're right.

    On 5.0.36-beta.8+c7d05ad2f, copy-paste works perfectly.

  • Thanks for reporting.
Sign In or Register to comment.