Inserting / updating Citation in LibreOffice adds extra linebreak at the end

Dear Zotero team and users,

I need a little help with what is probably a bug.

Whenever I add a citation that is formatted through a style that uses notes (footnotes or endnotes - this does not seem to make a difference), the note is correctly inserted and formatted, but an extra line break is added after the reference.

This not only adds an unwanted space between footnotes on insertion, which I could remove manually, it adds this space whenever the citation has to change (e. g. you correct the item's detail in your library and refresh), which means I'd have to hunt down these extra line breaks everywhere...

This is my setup: Ubuntu 17.10, LibreOffice, Zotero

I tried to reinstall the plugin for LO, but it didn't help.

Any idea is welcome...
  • What style are you using?
  • Sorry, I meant to say this but I forgot. This happens with any style that uses notes, e. g. "Chicago Manual of Style 17th edition (full note)" or even installing a random one such as "Bluebook Law Review".
  • Check your Footnote style in LibreOffice to see if the paragraph styling for footnotes is set to add space after the note.
  • I have the same problem as nchachereau for some days now. In addition to the line break, there is a further problem: If I add additional text before the citation in the footnote, one character of this additional text disappears with every citation update. "See: CITATION" will turn into "See:CITATION(line break)".

    My setup is: Ubuntu 16.04, LibreOffice, Zotero

    I can also confirm that this happens with any style that uses notes in my case.
  • edited February 9, 2018
    @bwiernik No this has nothing to do with LO styles - It is an actual line break character, not spacing. The character is added after every update: if I didn't remove it the first time, it will add a second one.

    @gwaihir68 Thank you for confirming that you experience the same issue. It is not my setup, then! I too noticed the removal of the last character before the citation but didn't think of it as related to the line break bug. Thanks for pointing it out!
  • Go into Zotero -> Tools -> Preferences -> Cite -> Word Processors and reinstall the libreoffice plugin, restart libreoffice and see whether that helps.
  • Thank you for your help!

    As stated in my initial message, I tried to reinstall the plugin for LO, but it did not help. I just tried again, just to make sure, but it did not make any difference.

    Since gwaihir68 noticed it started happening a few days ago, I guess it might have something to do with version 5.0.10 of the LO plugin? I wanted to downgrade to make sure, but it seems the only way is compiling the plugin myself, which I do not want to do right now.

    Could maybe someone provide me with a build of the LibreOffice plugin for version 5.0.9? (Or with a way of downloading one)

  • For the record I am on Ubuntu 16.04 with LO 6.0 and LO plugin 5.0.10 and cannot reproduce this. You can try the version 5.0.8 that was stable since November last year. We have pushed out both 5.0.9 and 5.0.10 over the course of the previous two weeks.
  • edited February 9, 2018
    Thank you for that link... but changing the LO plugin's version did not help either. :( (by the way, version 5.0.10 tells LO it is 5.0.8, so it is a bit confusing when testing).

    Since your setup is so similar, I tried more things out. Downgraded, upgraded LO to version 6 - no difference. Downgraded LO plugin even more (5.0.7) - no difference.

    Last piece of the puzzle: downgraded Zotero by installing Zotero 5.0.34 from CogSciNL's PPA: IT WORKS!

    So it seems that the plugin is not the cause. Having two Zotero versions installed I can even compare: in LO, with the same LO plugin, it works or does not work depending on the Zotero version I started.

    - there is a difference between the version of Zotero installed in my home folder and CogSciNL's packaged version of 5.0.34, or
    - (more probably) something changed between Zotero 5.0.34 and that introduced this bug.

    I hope this helps you to reproduce the bug, and squashing it in the end. In the mean time, I can use Zotero 5.0.34. A big thank to all of you.
  • Thank you @nchachereau and everybody else. Using Zotero 5.0.34 also solves the problem for me.
    I assume that the bug first appeared when Zotero was released on February 3. Updating to Zotero 5.0.35 did not help to solve it.
  • I managed to reproduce this in the end. A hotfix for Zotero 5.0.35 is out now that should resolve this. Thanks for reporting!
  • Thank you @adomasven! Updating to resolved it.
  • Unfortunately, I'm having the same issue and updating to didn't resolve it for me. I'm using Mac OS 10.13.3 and LO Even when adding a new citation, there is no space between the footnote number and the actual citation (even if there is no additional text in the prefix or suffix fields).
  • That's not at all the same issue (error was extra line break; your issue is missing space/tab) and I'm pretty sure that what you are seeing is actually controlled by LO's footnote styling and you should be able to fix it there.
  • Thanks @adamsmith. Sorry, I should have mentioned, I am having the same issue with the extra line break as well, although less frequent. Also, if it was a LO footnote styling issue, wouldn't it effect all my footnotes?
  • yes it would -- you're saying this is only in Zotero generated footnotes?
  • The far majority of my Zotero generated footnotes in my thesis are appearing correctly. Maybe only 10-20% of Zotero generated footnotes have either (or both) an extra line break or no space between the footnote number and the citation.
  • First, please go into Preferences -> Cite -> Word Processors and reinstall the LibreOffice plugin. Then, can you confirm what is wrong when inserting a new citation? It is best if you try this in a new document, to ensure default document settings.
  • Thanks @adomasven for your help. After reinstalling the plugin and testing it on a new document, everything works fine. When I try adding a new citation in my thesis, however, the error occurs again. So the thesis is the issue (in more ways than one). Any suggestions on how I might go about addressing the error in my thesis?
Sign In or Register to comment.