Managing notes from PDF attached to references

With the new version of Zotero for Firefox 5.0.25, I am not able to extract what I've been underlining in the PDF... I don't find the usual way to do it with the right click to extract data from the PDF. What's going on?

  • You need to download the current version of the Zotfile plugin and install it into the Zotero app:
  • Which one? I've try the zotfile.xpi but my browser (the charming Firefox) does not want to execute it...


    @jlegewie jlegewie released this 2 days ago · 1 commit to master since this release

    Fix problem with notifications that don't disappear


    469 KB
    Source code (zip)
    Source code (tar.gz)

  • You need to install it in Zotero, not Firefox:
  • Hi Zotero friends

    I've tried the zotfile.xpi but Firefox does not want to execute it.
    I ve tried what is written in:
    I can't install it in zotero because I cannot locate: zotfile-5.0.6-fx.xpi in theSource code (zip) .
    After many attempts I receive this message:
    "The add-on "%S" could not be installed. It may be incompatible with this version of Zotero."
    Please help trying to be more specific, if it is possible.

    Many thanks
  • (Please don’t double post in multiple threads.)

    You need to download the .xpi file not the .zip file.
  • To bwiernik : Firefox doesn't want to install the .xpi

    To adamsmith (Like the economist?) : I can't figure how to install it on Zotero... the link bring me to Firefox

    I'm thinking about changing my browser...
  • right-click --> save link as on the link to the xpi, then install as described on the Zotfile page.
  • Thanks, its solve now!
  • Thanks, its solved ! I didn't know I had to save it as a link. I was about to chamge browser too!!
  • I'm having a problem with Zotfile that I think may be a bug. I haven't read all 55 pages of this discussion, so maybe someone else has raised it. But I searched for "zotfile" and "multiple" without finding discussion of the issue.

    In my workflow, I often mine bibliographic information from databases like JSTOR and EBSCO. I find the reference and press the Zotero scraper button. If the reference has a pdf attached and I have access to the pdf, then Zotero attaches a copy of the pdf to the reference. Zotfile then steps in, copies the pdf file to my pdf database, and renames the pdf according to rules I've specified.

    Often I've already read the item and have a marked up, underlined version. So I scan it, attach the scanned copy to the reference in Zotero, and use Zotfile's Manage Attachments > Rename Attachments command to rename the marked version of the item and move it to my pdf database alongside the other copy. Now there are two copies: one plain (which I keep in case I want to share it with students or colleagues) and one marked up.

    Zotfile is smart enough to store the two versions with different names. The first version gets its name from the author, year, and title. The second version has th identical name, except Zotfile adds an integer to the end, starting with "2" and continuing to increment the counter for every version I add.

    But this only applies to the files themselves. Back in Zotero, each attachment now has the identical name. There are no integers added. And each link actually points to the first one.

    This creates more work. First I have to move all but one of the duplicate links to the trash. Next, I attach the the appropriate file that now resides in my pdf database. For instance, if the original version of the file is called Foo.pdf and the marked version is Foo2.pdf, then Zotfile will have given me two pointers to Foo.pdf. So I delete one of these pointers and replace it with a new one by attaching it to Foo2.pdf.

    Zotfile should be doing this automatically. IIRC, under Zotero 4 Zotfile handled this correctly, with the different links to attachments all actually pointed to different files. But now, they all point to a single file.

    This is a bug, no?
Sign In or Register to comment.